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1 INTRODUCTION 

1.1 WHAT IS CHRONOLATOR AND WHAT DOES IT DO? 

Chronolator makes it easy to produce the chronologies that are needed to review interactions 
between different agencies and organisations. Since it is based on Microsoft Word, little specialist 
knowledge is required to use it. There are no new programs to learn or install, and only a basic 
knowledge of working with Word tables is required.  

Chronolator has something to help everyone involved in using a chronology to investigate a case: 

 those who supervise and administer it; 
 the front-line staff who input the data; 
 those who review it. 

1.1.1 ADMINISTRATORS 

Gathering and collating chronologies from multiple agencies is a time consuming task, particularly 
if they each have different ideas about what they need to provide. Chronolator enforces the 
standards set by the administrator (for example, what column headings the chronology table 
should have) and automates the merging of individual chronologies. 

1.1.2 FRONT-LINE STAFF 

Transcribing written records from various sources into a consistent format is a tedious and 
error-prone task. Chronolator simplifies the process with a number of tools. There are tools to sort 
records into order, to put dates into consistent formats, and to check for a variety of problems. 

1.1.3 REVIEWERS 

The final objective of a chronology is that someone can make sense of the events it contains. 
Chronologies are often anonymised, which can make it difficult to build a mental picture of the 
people involved. The Chronolator anonymisation tool lets you switch back and forth between 
anonymised and personalised views of a document.  

Other tools for reviewers include: 

 reports about individuals identified in the Abbreviations Glossary; 
 colour-coding events according to the agency reporting them; 
 a calculator to work out the interval between two dates; 
 formatting a tabular chronology into a narrative layout. 
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1.1.4 THE CHRONOLATOR PROCESS 

The Chronolator process begins when the Case Review Administrator sets up an Internal 
Chronology1, which is a Word document containing a table whose headings and other 
characteristics are specified by the Administrator.  

The Case Review Administrator distributes the Internal Chronology to the various organisations 
whose data is required. 

If an organisation needs to collect data from several departments, the recipient can forward the 
Internal Chronology to them and ask them to complete it rather than calling for their original 
records.  Anyone forwarding a document in this way is called a Local Administrator. 

When the holders of the original records have completed their documents, they return them to 
the Administrator who wanted the information (either the Case Review Administrator or a Local 
Administrator). That Administrator uses Chronolator to merge them into a Composite 
Chronology2.  

There is no limit to the number of levels of Local Administration. 

The diagrams below (Figure 1 on page 11 and in Figure 2 on page 12) illustrate the flow of 
documents between administrators and data collectors.

                                                      

1 An Internal Chronology contains events from a single organisation or department 

2
 A Composite Chronology contains events from more than one organisation or department 
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Figure 1 - multiple levels of administration - schematic document flow 
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Figure 2 - multiple levels of administration - a possible scenario 
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1.2 ABOUT THIS DOCUMENT 

This document describes the Chronolator tools that help to complete, merge, format, and review 
chronology tables. 

It also contains some hints and tips about using Word tables in general, and a complete list of 
Chronolator messages.  

For information about the terminology used in this document (such as ‘Internal Chronology’ and 
‘Local Administrator’), see Appendix E - Chronolator Terminology on page 143. 

1.3 CHRONOLATOR DOCUMENTATION 

Setting Up Chronolator Documents  describes how to create Chronolator Documents using 
the Chronolator Online Workbench, and how to distribute them. 

Using Chronolator Documents  (this document) describes how Chronolator facilitates the 
production of accurate chronologies, how to combine Chronolator Documents into Composite 
Chronologies, and the other tools and features Chronolator provides. 

Using Chronolator Samples  contains some exercises you can undertake with the sample 
documents to acquaint yourself with the main features  of Chronolator. 

1.4 A NOTE ABOUT WORD VERSIONS AND OPTIONS 

The illustrations in this document were mostly taken using Word 2013 with a typical set of user 
options; your own experience might be slightly different. Separate instructions are provided for 
each Word version if there are marked differences.  

Chronolator documents are supplied in the docm format introduced with Word 2007. They can be 
opened in Word XP and 2003 if the Microsoft Office Compatibility Pack is installed. They can be 
saved in the old doc format if need be. 

1.4.1 LIMITED SUPPORT FOR WORD 2000 

Word 2000 is no longer supported by Microsoft. Macros in docm files are not supported in Word 
2000 even if the Compatibility Pack is installed. Word 2000 is therefore not suitable if you want to 
use the Chronolator Online Workbench. 

If you are using Word 2000 and your administrator has sent you an Internal Chronology as a docm 
file, ask them to save and send you a doc version.  

1.4.2 WORD FOR APPLE MAC 

Chronolator is designed for and tested on Windows versions of Word. It will certainly not work 
with Word 2008 for Mac, as it does not include the Visual Basic for Applications programming 
environment used to run macros. It might run OK on other versions of Word for Mac, but it is not 
tested on them and support is not guaranteed.  
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1.4.3 HOW CAN I TELL WHICH VERSION OF WORD I AM USING? 

The simplest way is to look at the 'splash screen'  Word displays while it starts. 

Word XP Word 2003 Word 2007 Word 2010 Word 2013 

     

 

Alternatively, type 'how can I tell which version of Word I am using' into a search engine. At the 
time of writing, the most useful link this revealed was on Microsoft's web site: 

http://office.microsoft.com/en-gb/word-help/what-version-of-office-am-i-using-
HA101873769.aspx.  

  

http://office.microsoft.com/en-gb/word-help/what-version-of-office-am-i-using-HA101873769.aspx
http://office.microsoft.com/en-gb/word-help/what-version-of-office-am-i-using-HA101873769.aspx
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1.5 VIEWING AND PRINTING THIS DOCUMENT 

1.5.1 CONVENTIONS AND SYMBOLS 

Text like this  generally denotes something on the screen that you can press. 

Text like this denotes a reference to a tool or function, or is used for general emphasis. 

Text like this refers to a document. 

Hyperlinks to other places in the document, or to other documents, are displayed like this. 

This symbol marks a hint or tip. 

 This one marks a Warning. 

1.5.2 ONLINE VIEWING 

This document is available in Word and PDF versions. 

We recommend the Word version for online reading. Use the Web Layout and Navigation Pane 

options on the View tab to avoid unnecessary page and table breaks and give you an overview of 
the document headings. Clicking on one of the headings in the Navigation Pane takes you to the 
relevant part of the document.  
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1.5.2.1 Hyperlinks 

The document also contains hyperlinks, which are displayed like this. Click on one to go to the 
relevant part of the document.  

We recommend that you add the Back button to the Quick Access Toolbar (QAT) on the ribbon so 
that you can go back to where you came from. Follow the instructions below to see how to do 
this. 

Press the small arrow to the right of 
the QAT, and click on More 

Commands . . .  

 

Under Choose Commands From , 
select Commands Not in the 
Ribbon. 

Scroll down to Back. 

Press Add >>. 

Press OK. 

 

The Back button is added to the 
QAT: 

 

 

Now, after you have followed a hyperlink, you can use the button to go back to where it occurred. 
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1.5.3 PRINTING  

For printing we recommend the PDF version of this document as it avoids any issues with page 
numbering.  

If you nevertheless want to print the Word version, note that Word resolves page references ‘on 
the fly’. To make sure they are correct when you print it, ensure that the relevant Word option is 
turned on as described below. 

1.5.3.1 Word 2003 and earlier 

Press Tools > Options > Print and tick the Update Fields box.  

 

1.5.3.2 Word 2007  

Press   >     > Word Options > Display and tick the Update fields before printing box. 

 

1.5.3.3 Word 2010 and Word 2013 

Press File > Options > Display and tick the Update fields before printing box. 

 

1.5.3.4 All versions 

If you get a message like this, select Update 
Entire table and press OK. 
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2 OPENING A CHRONOLATOR DOCUMENT 

Chronolator Documents are Microsoft Word documents with extra features. All standard Word 
features are available and work in the usual way.  

 If you receive a Chronolator Document as an email attachment, you should SAVE IT 
SOMEWHERE ON YOUR SYSTEM AND WORK ON THE SAVED COPY. This avoids the loss of work 
which can arise from working directly on any email attachment. 

2.1 MICROSOFT WORD MACROS 

Chronolator works by using Word ‘macros’. Because they are computer programs, macros can be 
used to propagate and run computer viruses. Word therefore allows you to prevent them running, 
since for most documents they are unnecessary. However, for Chronolator they are essential.  

When macros are allowed to run, Chronolator 
will ask you to confirm that you accept its 
licence terms. In that case, continue reading at 
Licensing on page 23. 

 

If the licence screen does not appear, you will need to ensure macros can run. The following 
section Enabling Macros shows you how.  

2.1.1 ENABLING MACROS 

Following the instructions given here will ensure that Chronolator can run without compromising 
your computer. 

2.1.1.1 Word 2003 and earlier versions 

Word 2003 and earlier versions display messages about macros as they open the document. For 
example, they might display a message like one of these: 

 

Press Yes. 

Continue 
reading at 
Licensing on 
page 23. 
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Press Enable Macros.  

Continue reading at Licensing on page 
23. 

 

 

Press OK and 
then refer to 
Word 2003 and 
earlier versions 
on page 87. 

 

2.1.1.2 Word 2007 and later versions 

Sometimes (usually if another document is 
already open) the later versions of Word will 
display a message like this when you open a 
document containing macros: 

 

 

 

 

 

 

Press Enable Macros.  

Continue reading at Licensing on page 23. 

However, these later versions sometimes do not tell you that a document contains macros until 
after they have opened it - and if your security settings are overly restrictive they might even 
disable them without telling you they are there! 

 If you are using Word 2007, see Word 2007 below; 
 If you are using Word 2010 or 2013, see Word 2010 and Word 2013 on page 20. 
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2.1.1.2.1 Word 2007  

The following pictures show what you might see after Word 2007 has opened the document.  

 

In this illustration, Word 2007 
informs you it has disabled macros 
by displaying a message under the 
Ribbon. 

If you see such a message, refer to 
Word 2007 displays ‘Security 
Warning Macros have been 
disabled’ on page 92. 

 

Here, the area between the Ribbon 
and the document is blank.  

If there is no Add-Ins  tab on the 
Ribbon, Word has probably disabled 
macros without telling you. 

If so, see Word 2007 or later 
versions do not display any warning 
about macros on page 89. 

 

2.1.1.2.2 Word 2010 and Word 2013 

Word 2010 introduced another level of security called ‘Protected View’ that a document must 
pass even before it is checked for macros. Protected View continues to work in the same way in 
Word 2013. 

Because this additional security can become tedious, Word 2010 and 2013 remember the choices 
you make. Once you have allowed a particular document to be opened with macros enabled, they 
will usually open in future without question. 

The next few paragraphs deal first with Protected View, and then with Enabling Macros. The 
pictures are from Word 2013, but what you need to do is the same for both versions. 
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2.1.1.2.2.1 Protected View – ‘Enable Editing’ 

Word might open a document in Protected View for a variety of reasons, and it is only possible to 
cover some common scenarios here. If you need more information, search Word’s Help for 
‘Protected View’ and read the article entitled What is Protected View? 

 

If you get a warning like 
this, press Enable Editing. 

 

If editing is prevented as 
shown here, see Protected 
View (Word 2010 and Word 
2013) on page 84. 

 

 

2.1.1.2.2.2 Enabling macros – ‘Enable Content’ 

When it comes to macros, Word 2010 and 2013 are similar to Word 2007 in two respects: 

 they do not tell you that a document contains macros until they have opened it; 
 if your security settings are overly restrictive they might disable macros without telling you 

they are there. 

In this illustration, Word 
2013 informs you it has 
disabled macros by 
displaying a message 
under the Ribbon. 

Press Enable Content  to 
enable them. 

 



 Using Chronolator Documents 

Version 3.3 Page 22 of 143 

Here, the area between 
the Ribbon and the 
document is blank.  

If there is no Add-Ins tab 
on the Ribbon, Word has 
probably disabled macros 
without telling you. 

If so, see Word 2007 or 
later versions do not 
display any warning about 
macros on page 89. 

 

 

You can find more information about setting up Microsoft Word macro security in Security 
Settings on page 84, or you might like to view one of the video tutorials about “Running Macros” 
at www.chronolator.co.uk/tutorials. 

  

http://www.chronolator.co.uk/tutorials
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2.2 LICENSING 

Chronolator is licensed software. If macros have been properly enabled, a Licence screen is 
displayed when you open the Online Workbench or a Chronolator Document:1 

 

 

Press OK  to continue using Chronolator.  

Press Cancel  if you do not agree to the 
licence terms. The document will close. 

Press View Licence  if you want to read the 
licence terms. 

Further details about licensing can be found 
in Appendix C on page 140.  

 

 

2.3 CHRONOLATOR TOOLBARS 

After you accept the licence terms, Chronolator creates a new Toolbar. Depending on the type of 
document, the contents of the toolbar may vary. The pictures below are of the toolbar in an 
Internal Chronology. 

In Word 2007 and later 
versions, the Chronolator 
toolbar is added to any 
other custom toolbars on 
the Ribbon’s Add-Ins tab.  

 

 

In Word 2003 and earlier 
versions, the Chronolator 
toolbar is added below 
your other toolbars  

 

 

 

If the toolbar does not appear, see The Chronolator toolbar does not appear on page 84. 

                                                      
1
 this only happens once in a particular Microsoft Word session. 
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2.4 THE INTERNAL CHRONOLOGY TOOLBAR 

The Internal Chronology toolbar provides a number of features to simplify the production of an 
accurate chronology which can easily be merged with others. These features are described in 
detail later on, but here is a summary of what they do: 

The Admin menu has buttons for various administrative tasks, such as: 

 viewing internal information about the document; 
 creating a Composite Chronology containing chronologies from different departments and 

organisations. 

The Tools menu helps you: 

 calculate the interval between two dates; 
 anonymise and re-personalise a document; 
 find duplicated rows; 
 highlight events according to the agency that reported them; 
 add reference numbers to a chronology, and specify the order of events on a day when 

their exact times are unknown; 
 use Chronolator Add-ins to provide added functions. 

The Format Dates menu changes dates and times to a consistent format, including options to 
include the day of the week. 

The Sort Tables menu sorts the rows of a table into ascending or descending date and time order. 

The Check Tables button checks the data in a document on demand (Chronolator also checks it 
when you close the document). 

The  buttons navigate from one error to the next. 

The Publish menu creates an exact copy of the document without any Chronolator macros. It also 
allows you to produce the chronology table in a number of narrative formats. 

The Help menu displays the Chronolator version and has links to some video tutorials. 
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3 CHRONOLATOR FEATURES - A SUMMARY 

3.1 ENTERING AND CHECKING EVENTS IN A CHRONOLATOR 
DOCUMENT 

Chronolator aims to make it as easy as possible to transcribe paper and other records into 
chronology tables. For example: 

 you can enter records as they become available and sort them later; 
 you can type in dates just as they are written, and let Chronolator put them in a consistent 

format; 
 Chronolator checks that the events in a chronology table are in order and that what is entered 

fits the criteria set by the Case Review Administrator.  

These data entry and checking features are described in Entering and checking events in a 
Chronolator Document on page 26. 

3.2 PRODUCING COMPOSITE CHRONOLOGIES  

Information is often needed from a number of different departments within an organisation. 
Chronolator speeds the process of getting this information by letting you forward an Internal 
Chronology to other people for them to complete. When they return their completed copies, you 
use Chronolator to combine them into a Composite Chronology. 

Creating Composite Chronologies is described in Creating a Composite Chronology document on 
page 37. 

3.3 ADVANCED FEATURES AND PRODUCTIVITY TOOLS 

Chronolator provides a number of other tools to facilitate working with chronologies. These are 
described in Advanced Features and Productivity Tools on page 43. 

3.4 PRACTISE USING CHRONOLATOR  

If you want to practise using Chronolator you can use the sample files supplied with it alongside 
the Using Chronolator Samples document. If you do not have these you can download them 
from www.chronolator.co.uk. 

3.5 GETTING HELP 

Chronolator provides a number of video tutorials which illustrate how to accomplish many of the 
tasks you need to undertake. Press Help > Tutorials on the Chronolator toolbar to see them. If 
they are not installed on your computer, you will be asked if you want to view them on the Web.  

http://www.chronolator.co.uk/
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4 ENTERING AND CHECKING EVENTS IN A CHRONOLATOR 
DOCUMENT  

A Chronolator Document consists of an optional preamble and one or more Chronology Tables1: 

 the Case Review Administrator can include a preamble containing details of the case and a 
brief description of how to use Chronolator; 

 the Chronology Table is where you enter details about the case under review.  

Chronolator ignores the document preamble, processing only the Chronology Table(s). 

 If you receive a Chronolator Document as an email attachment, you should SAVE IT 
SOMEWHERE ON YOUR SYSTEM AND WORK ON THE SAVED COPY. This avoids the loss of work 
which can arise from working directly on any email attachment. 

4.1 ENTERING DATA IN THE CHRONOLOGY TABLE 

Entering data into a Chronology Table requires a basic knowledge of working with Word tables – 
how to create a new row, how to move a row and so on. If you are unfamiliar with these ideas, 
you will find some hints and tips in Working with Microsoft Word tables on page 81. 

When a Chronolator Document is created, the Case Review Administrator specifies the rules which 
must be followed in the Chronology Table – for example, what the column headings are and which 
columns must always be completed. The Administrator should tell you what these rules are, either 
in the document preamble or in a covering letter. Chronolator checks that the data you enter 
conforms to these rules every time you close the document, and warns you if it finds any 
problems. You should correct any errors before returning the document. 

It is essential that you do not change, add or remove any headings in the Chronology Table, as 
Chronolator relies on them to check the data you enter. You can change the font2, the column 
widths, the shading and so on, but you must not change the heading text or add or remove 
columns. 

If you accidentally change the headings and forget what they should be, you can generate a 
new set at the end of the document by pressing the Admin > New Table button on the 
Chronolator toolbar. After doing this, either copy any data you have already entered into the new 
table, or copy the heading row from the new table into that of the old one. 

  

                                                      
1 Usually only one. 

2 Chronolator always formats the chronology table with the Normal style. If you want to ensure that changes you make to the font are preserved during Chronolator  
processing, you should update the Normal style. Refer to Word Help for more information about formatting a document with styles. 
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4.2 SPECIAL COLUMNS 

Chronolator treats most of the columns in a chronology table as free-form text, only checking 
them if the Case Review Administrator has deemed them mandatory. However, some columns 
play a major role in the way a Chronolator Document is processed.  

These special columns are briefly described below.  

Chronolator's names for them are shown like this, but the Case Review Administrator can give 
them different headings in the actual chronology table. 

4.2.1 EVENT ORDER: DATE,  TIME AND SEQUENCE COLUMNS 

Up to five special columns can be used to specify when an event happened:  

 Sequence (optional) 

 Start Date (mandatory for all Chronolator Documents) 

 Start Time (optional) 

 End Date (optional) 

 End Time (optional) 

Chronolator can populate the Sequence column with event reference numbers. It can also be used 
to specify the order of events on a particular day when you do not know their times. If you need to 
do this and the Administrator has not included one, you can add a Sequence column using the 
Tools > Sequencing > Add column button. (This is the only change Chronolator allows to 
Administrator-defined column headings).  

4.2.1.1 Dates 

Chronolator allows you to enter dates in many formats. For example, all the following will be 
recognised: 

 22.05.04 
 22-may-04 
 22/05/04 
 22/05/2004 

Chronolator expects a Date column to contain a single date and no other words or characters. For 
example ‘? 22 may 2004’ or ‘probably 22 may 2004’ would not be allowed. 

If you are unsure of the exact date of an event, enter your best estimate and note that you 
have done so in one of the other columns. Similarly, if you want to enter a range of dates and the 
Case Review Administrator has not included  an End Date column, enter the first date in the Start 
Date column and the other date in one of the other columns. 

The Format Dates menu on the Chronolator toolbar lets you set all the dates you have entered 
into a consistent format. 
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4.2.1.2 Times 

Chronolator is also flexible about the formats used in any Time columns in the table. For example, 
the following will all be recognised: 

 0100 
 01.00 
 01:00 
 1 am 
 01 am 

The Format Dates menu on the Chronolator toolbar also puts all the times you have entered 
into a consistent format; all the above would become ’01:00’. 

4.2.2 SOURCE OF INFORMATION COLUMN 

After the Event Order columns comes the Source of Information column, where you specify the 
source of your information about the event. 

When entering the source of your information, do not include your own organisation or 
department. This information will be added by the Administrator who sent you the document.  

For example, suppose you work at the Berrick New Town Clinic and are entering data you have 
obtained from a Health Visitor’s notes. You should record the source of information simply as, say, 
HV notes, not as Berrick New Town Clinic HV notes. The administrator who sent you the 
document will add ‘Berrick New Town Clinic’ when using Chronolator to combine documents. (You 
can see an example of this in Specify where the document came from on page 40). 

4.2.3 GLOSSARY COLUMN 

A Glossary column can be included which should contain only abbreviations that have been 
defined in the Abbreviations Glossary - for example, somebody's initials. This can be useful when 
a chronology contains information pertaining to more than one person. Chronolator will check 
that anything in this column has been defined in the Abbreviations Glossary.  

You can view the glossary and add your own abbreviations to it by pressing the Admin > 

Abbreviations button on the Chronolator toolbar. Each abbreviation can be up to ten characters 
long, and its definition up to thirty. 

You can anonymise and personalise a document by using the Abbreviations Glossary in 
conjunction with the Tools > Anonymisation button. 

4.2.4 MANDATORY COLUMNS 

Chronolator insists that the Start Date and Source of Information columns must always be 
completed. The Case Review Administrator decides what other columns are mandatory. 
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4.2.5 FINDING WHAT SPECIAL COLUMNS ARE INCLUDED 

The Admin > Show Document Details button on the Chronolator toolbar displays a summary of 
what special columns and abbreviations the Case Review Administrator has set up. 

It will usually be obvious from the column headings what type of data is expected. If not, ask the 
person who sent you the document to explain them.  
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4.3 CHECKING DATA 

Chronolator checks your Internal Chronology 
document every time you close it. If it finds 
errors, it displays this message. 

Press Cancel to keep the document open so 
you can correct the errors.  

Press OK if you want to correct them later. 
The document will close. 

 

You can also check the document whenever 
you want by pressing the Check Tables 
button on the Chronolator toolbar: 

 

 

If the document is error-free it will tell you. 

 

If the document contains errors, this 
message is displayed. The number in 
brackets says how many errors were found. 

Like all Chronolator messages, it has 
some suggestions about what you might do 
next. In this case, the message describes how 
you can find out more about the errors. 

 

There are several ways for you to find the errors Chronolator reports: 

 A flag like this is put at the left of the error.  
 Hovering your mouse over the flag displays a brief description like this: 
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 Error text is highlighted. Invalid data is coloured turquoise, valid dates or times which are out 
of sequence are coloured yellow, and rows with the wrong number of columns are coloured 
purple; 

 You can use the navigation buttons on the Chronolator toolbar to go from one error 
to the next. This is useful if you are working in a long document; 

 There is a complete list of errors at the end of the document. Use the  button to the right of 
the navigation buttons to go there. 

4.3.1 CORRECTING ERRORS 

The following example1 illustrates the sort of errors Chronolator discovers, and shows how you 
might go about correcting them. 

In this example, the Administrator has specified that you can leave any column blank apart from 
the Date and Source of Information columns. 

The text in the Comments column describes the sort of errors Chronolator will find. It is not 
itself part of Chronolator’s checking. 

 

Figure 3 - faulty Chronology Table before checking 

After Chronolator checks the table, it puts a flag  to the left of any errors and highlights them like 
this: 
 

                                                      
1
 taken from SampleTableWithErrors.docm in the Samples folder 
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Figure 4 - faulty Chronology Table after checking 

If you hover your mouse over 
the flag, a brief description of 
the error pops up. 

Here, Chronolator warns that 
it has corrected a row with the 
wrong number of columns and 
advises the user to check that 
it has put information under 
the right headings. 

 

In this example, Chronolator 
has detected a blank entry in a 
mandatory column. 

 

The buttons on the 
Chronolator toolbar navigate  
from one error to the next. 

  

This button takes you to a list 
of the errors. 
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The list of errors is at the end 
of the document. 

Double-click the  flag to go 
to where the error occurs. 

 

  

Error descriptions are preceded by a reference number (e.g. ‘c8n210’). If you have difficulty 
correcting an error, use the reference number to look it up in Check Table Error Codes on page 
137, where there might be some useful hints. 

 

 CAUTION: ANYTHING YOU WRITE IN OR AFTER THE ERROR LIST WILL BE DELETED NEXT 
TIME CHRONOLATOR CHECKS THE DOCUMENT. 

 

How you correct errors in a real document will obviously be a matter of judgement. For the 
purposes of this example, this is what we will do: 

 add text to all the mandatory columns; 
 review the rows which had the wrong number of columns, which are highlighted like this. In 

this case we decide that Chronolator has placed the data correctly, and leave it where it is; 
 correct the invalid Date ’34 may 2013’ to ‘14 may 2013’. 
 copy and paste the required data over the ‘See above’ text, and delete the ditto marks and ‘as 

above’ text. 

The table now looks like this: 



 Using Chronolator Documents 

Version 3.3 Page 34 of 143 

 

 

Notice that the corrected errors are still flagged and highlighted (apart from the ones we 
corrected with copy and paste). Chronolator does not check for errors as you type because doing 
so would make your computer run very slowly. You need to check the document again . . . 

Pressing the Check Tables button again results in this: 

 

 

Most of the problems Chronolator has found are out-of-sequence dates, which it has highlighted 
in yellow. You could correct these by moving the rows about or by changing the dates for the 
appropriate events, depending on what is appropriate for the data you have entered. 
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4.3.2 THE SORT TABLES  BUTTON 

In the example above, you might decide that each event was in fact correctly dated but that the 
rows were in the wrong order. Indeed, this is the most likely cause if you have been entering each 
event in a new row at the bottom of the table as it came to hand. Chronolator will fix this for you 
with the Sort Tables button:  

 

When you press it, you can choose to sort the table in ascending or descending order; press the 
one you want. If you press Ascending, the table is sorted like this: 

 

 

Remember, Chronolator does not check errors as you type; press the Check Tables button 
again to remove the highlighting: 
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All the events are now in order. Some errors remain, but we will leave them for now. 

You might have entered dates just as they appeared in the source records; in the example 
above, that is why many of the dates are in different formats. Chronolator can put them all into a 
consistent format for you; see Format Dates on page 41 for details. 

4.3.2.1 How does Chronolator sort events with blank times and End Dates?  

The Case Review Administrator might include optional End Date, Start Time or End Time columns 
which might not have to be completed for every event. 

If so, you might wonder how Chronolator will deal with a mixture of events, some with completed 
times or end dates and some with blanks. 

The answer depends on whether events are sorted in Ascending or Descending order. If 
Ascending, events with blank times or End Dates are put before those with specific information: if 
Descending, after. The following examples illustrate this. 

Ascending order 

 

Descending order 
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5 CREATING A COMPOSITE CHRONOLOGY DOCUMENT 

This section describes how to merge individual Chronolator Documents into Composite 
Chronologies.  

5.1 ADMINISTRATORS 

A Composite Chronology is produced by an Administrator. In Chronolator terminology, there are 
two kinds of Administrator: 

 Case Review Administrators have a licence for the Online Workbench and use it to set the 
criteria for an Internal Chronology;  

 Local Administrators are people who, when they receive a Chronolator Document, decide to 
delegate completing it to several other people in their organisation. 

A Local Administrator distributes copies of the document to other people and merges them 
into a Composite Chronology when they have been completed. 

When the Composite Chronology has been completed, a Local Administrator returns it to the 
person who asked them for the information.  

The flowcharts in Figure 1 on page 11 and in Figure 2 on page 12 illustrate the flow of documents 
between administrators and data collectors. 

The only difference in administrators’ procedures is that a Case Review Administrator should use 
the Online Workbench to create a new Composite Chronology, while a Local Administrator must 
use the Chronolator Document toolbar1. 

5.2 OVERVIEW 

Creating a new Composite Chronology involves the following steps: 

 Make a blank Composite Chronology document;  
 Import tables from the Chronolator Documents that have been returned to you; 
 Merge the tables; 
 Format the dates;  
 Sort the tables; 
 (Optional) Apply any final formatting that is required; 
 (Optional) Publish the document with the Chronolator code removed. 

You can wait until you have received all the documents before starting this process, or you can 
import, merge, format and sort each one as it comes in. It is up to you. 

The following sections describe these processes step by step. 

                                                      
1 Using the Online Workbench to create the Composite Chronology ensures that it is licensed for as long as the Online Workbench. Composite Chronologies created from 
an Internal Chronology are only licensed for the same period as the Internal Chronology. 
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5.3 STEP BY STEP GUIDE 

5.3.1 MAKE A BLANK COMPOSITE CHRONOLOGY DOCUMENT 

How you make a blank Composite Chronology depends on what type of administrator you are: 

 

If you are a Case Review Administrator If you are a Local Administrator 

 

Press the New Composite Chronology 
button on the Online Workbench toolbar. 

Press the Admin > New Composite Chronology 
button on the Internal Chronology toolbar. 

 

 

 

Chronolator displays Word’s Save As dialog 
for you to choose what to call the new 
Composite and where to save it. 

Enter a suitable name and location and 
press Save.  

If you are a Local Administrator, the 
Internal Chronology closes and the 
Composite Chronology is opened.  

If you are a Case Review Administrator, the 
Online Workbench stays open when the 
Composite Chronology is created. You 
might need to switch to the Composite 
Chronology using the Windows taskbar.  

 

 

From this point on, there are no differences between what Case Review Administrators and 
Local Administrators do to produce a Composite Chronology. 
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5.3.2 IDENTIFY THE COMPOSITE CHRONOLOGY TOOLBAR 

The Composite Chronology has a 
new toolbar. Chronolator never 
displays buttons for irrelevant 
tasks, so a new Composite 
Chronology contains just two 
buttons.  

After you have imported the first 
document, the toolbar expands 
to include buttons for the other 
tasks that become possible. 

 

5.3.3 IMPORT CHRONOLOGY DOCUMENTS INTO THE COMPOSITE 
CHRONOLOGY 

 

5.3.3.1 Identify and check a file to import 

Although Chronolator will have warned people if it found errors in their documents, it cannot 
force them to correct them. Before you import a document, you should open it and check it using 
the Check Tables button on its own Chronolator toolbar. 

If the document has errors which you cannot correct yourself, ask the person who sent it to you 
for clarification, or return it to them for correction; it is better to sort things out now rather than 
later. 

If you are satisfied with the document, close it and return to your Composite Chronology. 

5.3.3.2 Press the Import Tables button 

Press the Import Tables button to display Word’s Open dialog. Open the document you want to 
import. 

When you import a document into a new Composite Chronology, Chronolator copies in 
the entire document, including its preamble (if any) and the internally stored Case Details.  

When you import subsequent documents, Chronolator checks that they relate to the same 
case and copies all tables1 matching the Case Details to the end of the Composite Chronology. 

  

                                                      
1 There should only be one, but it is possible that someone might inadvertently have created more. Chronolator will copy all tables which match the Case Details set by 
the Case Review Administrator. 
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5.3.3.3 Specify where the document came from 

 

After checking that the document contains 
tables with the right headings, Chronolator 
asks you to identify where it came from. For 
example, if you were to import a document 
from the Police, you might enter this: 

 

 

When you press OK, ‘Police >’ will be added to whatever is already in the Source of Information 
column. 

 

For example, if the Police’s document 
contains these entries . . . 

 

. . . after you have imported it, they will 
look like this: 

 

 

 

You can import all the documents you have to hand before proceeding to the next step, or you 
might prefer to import, merge, and format them one by one. It is up to you. 

5.3.4 MERGE TABLES IN A COMPOSITE CHRONOLOGY 

Use the Merge Tables button to 
combine all the tables in the 
Composite Chronology into a 
single table. 

 

Chronolator automatically resizes any tables whose column widths are different from those of the 
first table. 
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5.3.5 FORMAT DATES 

The various organisations and departments who completed the Internal Chronology documents 
you distributed will probably have entered dates in a variety of different ways (01.02.04, February 
1 2004, 1/2/4 and so on). This does not hamper Chronolator’s validity checks, but it does look 
untidy.  

You can use the Format Dates button to 
put them all into a consistent format. When 
you press it, you will see today’s date 
displayed in four different formats. Press 
the format you want. 

 

The available formats present January 2 2001 as 02 Jan 2001 or 2001-01-02. The latter is the ISO1 
8601 format. Both formats can be enhanced with the day of the week, which can be useful for a 
reviewer trying to establish patterns of behaviour. 

When you format dates, any Time columns are also formatted. The format conforms to ISO 
8601 (a 24-hour time delimited by a colon, e.g. 18:15). 

5.3.6 SORT A CHRONOLOGY 

Use the Sort Tables button to sort 
the merged table into the correct 
order. When you press it, a menu 
drops down so you can choose 
whether to sort the table in 
ascending or descending order. 

 

Press the order you want. Chronolator will sort the table using the Date and Time columns that 
the Case Review Administrator specified.  

Chronolator puts untimed events for a particular day before timed events when sorting in 
Ascending order, or after them when sorting in Descending order. See How does Chronolator sort 
events with blank times and End Dates? on page 36 for an example. 

 

5.3.6.1 Sorting mixed formats 

Putting dates and times into a consistent format before sorting is recommended as it makes the 
sort easier for Word, and thus more reliable. 

Early versions of Word had a bug which prevented Sort from working in some circumstances. 
Circumventing that bug was the reason for introducing the ISO 8601 format, which Word 
unfailingly sorted correctly. If you do encounter problems sorting, try this: 

                                                      
1
 International Standards Organization 
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 Press Format Dates and choose the ISO 8601 format;  
 Press Sort Tables; 
 Press Format Dates again and choose your desired format.  

5.3.7 FINAL CHECKS 

You can use the Check Tables 
button to make a final check that 
the Composite Chronology is valid 
as far as Chronolator is concerned.  

 

You should also read through the document to make sure it makes sense. Chronolator 
certainly simplifies the process of producing these documents, but it is only a computer 
program and cannot correct human failings! 

In particular, you might want to check that any time-critical events are in sequence if the 
document does not contain Chronolator’s Start Time or Finish Time columns. If they are not, 
consider using a Sequence column. 

5.3.8 PUBLISHING A CHRONOLOGY DOCUMENT 

When you have completed a chronology document you can publish it without the Chronolator 
program code so that your recipients will not have to do anything about macros and licence terms 
whenever they open it. 

Pressing Publish > Exact Copy 
copies everything to a new 
document, and then displays 
Word’s Save As dialog so you can 
choose where to save it. 

 

The original Chronolator document is unchanged by this process. 

You can also publish the chronology in a variety of narrative formats. See Narrative formats on 
page 67. 
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6 ADVANCED FEATURES AND PRODUCTIVITY TOOLS 

Most of the advanced features of Chronolator are on the Tools menu: 

 The Age and Interval Calculator - see The Age and Interval Calculator below. 
 Anonymisation and Personalisation, including review of selected abbreviations - see 

Anonymisation and Personalisation on page 55; 
 Duplicate Row Processing - see Working with Duplicated Rows on page 46; 
 Adding reference numbers to events, and using them to force the order in which they are 

sorted - see Using a Sequence column on page 59; 
 Highlighting events according to their Source of Information - see Highlighting Sources of 

Information on page 64; 
 Using Add-ins, which add extra functions to Chronolator - see Add-ins on page 71.  

Items on the Publish menu let you create versions of a chronology without any Chronolator code, 
and in a variety of narrative formats - see Publishing a chronology on page 67. 

On the Admin menu, Abbreviations lets you update individual entries in the Abbreviations 
Glossary - see Working with the Abbreviations Glossary on page 50. 

6.1 THE AGE AND INTERVAL CALCULATOR 

You will often want to work out the 
interval between two dates when 
working on a chronology. Chronolator 
provides a tool to do this for you when 
you press Tools > Age Calculator on 
the Chronolator toolbar. 

 

 

If you have not used the Age and 
Interval Calculator before in this 
document, Date 1 has today’s date in 
it, and Date 2 is blank. 

If you have used it before and 
saved the document, the last two 
dates you used will be shown. 
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You can type dates into the boxes in 
many formats. As you type, 
Chronolator displays what it thinks you 
mean next to the box. 

When Chronolator can interpret dates 
in both boxes, it calculates the interval 
between them.  

The interval is shown as a number of 
days and as a number of years, months 
and days. 

It does not matter which date is 
the earlier one. 

 

You can copy the interval information to the Clipboard by pressing the Copy button, and then 
paste it into your document. The example above is copied to the Clipboard as 10 years, 11 
months, 24 days (4011 days). Once pasted into the document, you can edit it as you choose. 

Using the Age and Interval Calculator is quite straightforward, but it is worth noting some details 
about how it works under certain circumstances. (If you are not interested in the minutiae of Date 
calculations, stop reading now and just use the calculator!). 

6.1.1 AWKWARD CALENDARS 

‘Thirty days has September, April, June and November’… We are taught this rhyme when we are 
young, and learn to cope with the different number of days in each month over many years. 
However, innocent as it sounds it provides many a stumbling block when working out the interval 
between two days. The numbers of days between two dates is always unequivocal, but if we want 
to give this as ‘x Years, y Months, z Days’ we come across problems of interpretation. The 
following sections give examples of these problems and describe how Chronolator deals with 
them. There is no single ‘right method’; we hope that Chronolator’s results match most people’s 
interpretations.  

6.1.2 EASY CALCULATIONS 

When the Day number of the later date is equal to or larger than that of the early date, things are 
quite straightforward: 

 

Early Date Late Date Interval  

23 January 2001 25 June 2002 1 year, 5 months, 2 days  

01 December 2001 02 January 2002 0 years, 1 month, 1 day  
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6.1.3 SLIGHTLY HARDER CALCULATIONS 

When the Day number of the later date is less than that of the early date, things can get a bit 
harder. However, as long as the Day number of the early date is less than or equal to the number 
of days in the month before the later date, there is not too much of a problem: 

 

Early Date Late Date Interval  

31 January 2001 01 June 2002 1 year, 4 months, 1 day  

 

Most people would probably work this out as follows: 

1. One year from 31 January 2001 = 31 January 2002; 
2. Adding 4 months takes us to 31 May 2002; 
3. Adding 1 final day gets to our target, 01 June 2002; 
4. That is, 1 year, 4 months, 1 day in all. 

So far, so good! 

6.1.4 DIFFICULT CALCULATIONS 

Now look at what happens when the Day number of the early date is more than the number of 
days in the month before the later date:  

 

Early Date Late Date Interval  

31 January 2001 01 May 2002 ?? 

 

Comparing this to the previous example, 01 May 2002 is exactly one month earlier than 01 June 
2002, so we might expect the answer to be exactly one month less; that is, 1 year, 3 months, 1 
day. 

However, if we use the same method as above: 

1. One year from 31 January 2001 = 31 January 2002 
2. Adding 3 months takes us to 31 April 2002!  
3. But April only has 30 days, so we must already have arrived at 01 May 2002. 

That being the case, our interval is 1 year, 3 months, 0 days in all - one day less than expected! 
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6.1.5 THE CHRONOLATOR SOLUTION 

The Age and Interval Calculator works so that the above ‘surprise’ does not occur. From a date at 
the end of a month to the first of another month is always x Years, y months, and 1 day. For 
example: 

   

Early Date Late Date Interval  

31 January 2001 01 May 2002 1 year, 3 months, 1 day  

30 April 2001 01 March 2004 2 years, 10 months, 1 day  

31 May 2004 01 December 2005 1 year, 6 months, 1 day 

 

This solution looks very plausible, but it does give rise to an anomaly. For example, the interval 
from 30 January to 01 May is the same as that from 31 January! 

 

Early Date Late Date Interval  

30 January 2001 01 May 2002 1 year, 3 months, 1 day  

31 January 2001 01 May 2002 1 year, 3 months, 1 day  

 

On balance, we feel that this solution most likely does accord with what most people want. 
However, if you disagree, please let us know by making a suggestion at 
www.chronolator.co.uk/suggest_form.htm. 

6.2 WORKING WITH DUPLICATED ROWS 

 

Use Tools > Duplicates to highlight or delete 
duplicated rows.  

 

 

6.2.1 HOW DUPLICATED ROWS CAN OCCUR 

Duplicated rows can occur for various reasons. For example: 

 you might have broken off completing an Internal Chronology for a while, and inadvertently 
entered the same records twice; 

 someone might send you a new version of an Internal Chronology containing a few extra 
events when you have already merged the original into a Composite Chronology. Rather than 

http://www.chronolator.co.uk/suggest_form.htm


 Using Chronolator Documents 

Version 3.3 Page 47 of 143 

having to pick through it all and take out the new events, you can import the new document in 
its entirety and let Chronolator identify and delete them. 

Sometimes however, duplicates - or near-duplicates - might occur for other reasons. It could be 
that two different agencies report the same event in exactly the same way. Although this might be 
unlikely, Chronolator is designed to help you identify and analyse potentially duplicated events 
however they occur. 

6.2.2 HIGHLIGHT OR DELETE? 

Chronolator can either highlight duplicated rows or delete them. You might want to highlight and 
review them before deleting them. 

If you wish, Chronolator will save deleted duplicates in a separate document. 

6.2.3 IGNORING THE SOURCE OF INFORMATION WHEN IDENTIFYING 
DUPLICATES 

You can instruct Chronolator to ignore the Source of Information column when looking for 
duplicates. You might want to do this if you have inadvertently imported a Chronolator Document 
twice using two different Source Prefixes. 

6.2.4 EXAMPLES 

The various options are illustrated below using the following table. Although somewhat 
implausible, it does provide a useful illustration of the options. 

All four rows are identical, with the exception of the Source of Information entry in the second 
row. 
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6.2.4.1 Highlighting duplicates 

When you press Tools > Duplicates > Highlight, the 
Duplicate Rows form is displayed: 

 

It contains a check box labelled Ignore source 
column.  

 

 

If you leave the check box 
blank and press OK, only 
the last two rows will be 
highlighted: 

 

In contrast, if you tick the 
box before pressing OK, the 
last three rows will be 
highlighted: 

 
 

The navigation buttons on 
the Chronolator toolbar can 
be used to go from one 
duplicate row to the next in 
a long document. 
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6.2.4.2 Deleting duplicates 

When you press Tools > Duplicates > Delete, the 
Duplicate Rows form is displayed with an extra 
option: 

 

 

 

 

 

If you want to save any rows which are deleted in a 
new document, tick the Copy Deleted Rows check 
box. 

  

After you press OK, Chronolator tells you it has 
deleted some duplicates (3 in this example). 

 

 

Press Go to list to switch to the new document 
containing the deleted rows.  

The description of Message 3031 on page 116 has 
some suggestions about how you can use the new 
document to recover the deleted rows should you 
wish to do so.  
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6.3 WORKING WITH THE ABBREVIATIONS GLOSSARY 

The Case Review Administrator can define entries in the Abbreviations Glossary of a new Internal 
Chronology1. Those entries cannot be changed or deleted by anyone else. 

Anyone can add and change their own entries. Chronolator keeps track of what abbreviations 
have been defined in which document. 

Abbreviations can be up to 10 characters long, and their Definitions up to 30. 

6.3.1 VIEWING AND PRINTING ABBREVIATIONS 

 

Press Admin > Abbreviations: 

 

The Abbreviations Glossary form is displayed showing the 
abbreviations in the document and their definitions:  

 

The Defined by / in column shows where an abbreviation has 
been defined. In an Internal Chronology, it will state either 
‘Administrator’ or ‘This Document’. In a Composite Chronology, it 
will include the path to any imported documents, as shown 
above. 

If you want to produce and  print a list of the abbreviations, press 
the Save as Document button. 

When you have finished, close the form by pressing the Close 
button. 

  

                                                      
1
 See Setting up Chronolator Documents for details about how to do this 
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6.3.2 ADDING AN ABBREVIATION 

 

Press Admin > Abbreviations: 

 

The Abbreviations Glossary form is displayed showing the 
abbreviations in the document and their definitions:  

 

Type the new Abbreviation and 
its Definition in the boxes, and 
press Add: 

 

The new entry is added to the list: 
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6.3.3 CHANGING AN ABBREVIATION 

Since agencies can add their own entries to the Abbreviations Glossary, it is possible that two of 
them might add similar entries (for example, AD/Alan Daniels and AD/Adam Donoghue).  
Chronolator always keeps track of where an abbreviation has been defined, but if you want to use 
the Anonymisation feature all abbreviations and definitions must be unique.  

You can use the Admin > Abbreviations tool to change a user-defined Glossary entry. Chronolator 
updates the glossary and makes any required changes in the document.  

The following example uses the Abbreviation GP1 and corresponding Definition Arthur Clements 
shown in the example above. The document text contains this event (Arthur Clements is in 
column 4, and GP1 in column 5): 

 

Press Admin > Abbreviations: 

 

The Abbreviations Glossary form is displayed. 

Click GP1 Arthur Clements. and press 
Change. 

 

The current abbreviation and definition 
appear in the boxes near the bottom of 
the form, with a message inviting you to 
change them: 
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Type in the new information and press 
the Change button to the right of it. In 
this example, we change both the 
Abbreviation and the Definition to GP99 
and Xaviera Yarrup respectively, but you 
can choose just to do either one. 

 

Use the scroll bar at the bottom of the 
abbreviations list to scroll it to the right. 

The original entry is still there, so you can always find 
it in the document in which it was first defined: 

 

 If you are using this feature to anonymise a 
document, remember not to publish it without first 
using the Publish > Exact Copy  tool to produce a 
copy without any Chronolator code, and hence 
without the ability to reveal the abbreviations. 

Press the Close  button in the bottom 
right hand corner of the form. 

Chronolator updates the document with the changed 
entry: GP1 and Arthur Clements are changed to GP99 
and Xaviera Yarrup respectively: 
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6.3.4 BROWSING A DOCUMENT USING THE ABBREVIATIONS GLOSSARY 

The Review button on the Abbreviations form lets you use a glossary entry to navigate through 
the chronology. You can also produce extracts containing just the events pertaining to an entry. 

For example, suppose you want to 
scroll through a document looking 
for events involving, say, GP1. Press 
Admin > Abbreviations, select GP1, 
then press Review. 

 

For further details, see Reviewing and changing how entries in the Abbreviations Glossary appear 
in the text on page 56. It uses the Review  button on the Anonymisation form, which lets you 
process more than one glossary entry at a time - you can only process a single one with the 
Review button on the Abbreviations Glossary form. 
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6.4 ANONYMISATION AND PERSONALISATION 

Chronolator can anonymise a document according to the entries in the Abbreviations Glossary. It 
can be hard for a reviewer to build up a mental picture of the people involved in a review when 
they are only referred to by their initials, so Chronolator lets you switch between anonymised and 
personalised views. 

The Anonymisation feature is found at Tools > 

Anonymisation  

 

 

6.4.1 WARNING 

The Anonymisation feature can format 
abbreviations like this to make them stand 
out in the document. This formatting will be 
lost when some other features are run, so it 
is recommended that you do not use 
Anonymisation until you have finished with 
those other features.  

Chronolator warns you about this by 
displaying Message 7010 the first time you 
press Tools > Anonymisation in a Word 
session. 
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6.4.2 SWITCHING BETWEEN ANONYMISED AND PERSONALISED VIEWS OF A 
DOCUMENT 

 

When you press Tools > Anonymisation 

(and OK on Message 7010 if it is issued), 
the Anonymisation  form is displayed 
showing the abbreviations in the document 
and their definitions. 

Place a tick against the abbreviations you 
want to process. The All, None, and Flip  
buttons at the top of the form can make 
this quicker. 

 

After you have selected one or more 
abbreviations (in the example here, all have 
been selected) the Anonymise and 
Personalise buttons work together with the 
Use formatting checkbox. 

 

If the Use formatting checkbox is ticked when a document is being Anonymised, the resulting 
abbreviations will be formatted like this (i.e. Bold, Underlined and Italic). This has two 
advantages: 

 abbreviations stand out in the document; 
 Chronolator can distinguish between entries in the Glossary and any common words which are 

spelt the same (for example, if there were an abbreviation The for Timothy Henry Edwards).  

If the Use formatting checkbox is ticked when a document is being Personalised, only those 
occurrences of an abbreviation which are formatted like this will be changed. 

6.4.3 REVIEWING AND CHANGING HOW ENTRIES IN THE ABBREVIATIONS 
GLOSSARY APPEAR IN THE TEXT 

The Review button on the Anonymisation form lets you use glossary entries to navigate through 
the chronology.  

During the review, you can change how individual entries appear in the text (as Abbreviations with 
or without highlighting, or as Definitions).  

You can also produce extracts containing just the events pertaining to selected entries. 
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Suppose we are interested in GP1/Arthur Clements and Midwife1/Paula Johnson. 

 

Press Tools > Anonymisation to display 
the Anonymisation form, then tick GP1 
and Midwife1, and then press the Review 
button: 

 

 

The Change Abbreviations form is 
displayed, and occurrences of the entries 
are highlighted in the document. 

The active occurrence is highlighted  like 
this, and the others like this. 

 

Use the navigation buttons in the form to 
scroll among the occurrences of 
GP1/Arthur Clements and 
Midwife1/Paula Johnson: 

 

 

 

The radio buttons let you change the text 
of the active occurrence to whatever you 
select: 

 

When you have finished, press OK or 
Cancel, depending on whether you want 
to save any changes.  
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6.4.4 PRODUCING AN EXTRACT OF EVENTS CONTAINING SELECTED 
GLOSSARY ENTRIES 

You can produce a new document containing just the events pertaining to selected glossary 
entries. 

Press Tools > Anonymisation: 

 

Select the entries in which you are 
interested, then press the Review 
button: 

 

 

When the Change Abbreviations 
form is displayed, press the 
Report button: 

 

A new document is created, 
containing only those events 
which involve the glossary entries 
you selected: 

 

 

The counts at the top of the report pertain to the abbreviations originally selected in the 
Anonymisation form, not those listed in the report. Changes you make before pressing Report will 
not be reflected in these counts. Similarly, if some abbreviations are formatted, the report counts 
might not match the highlights in the report.   
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6.5 USING A SEQUENCE COLUMN 

The first column in a chronology table can be a Sequence column, which provides two main 
benefits: 

 it can contain a reference number for each event;  
 you can use it to specify the order of events on a particular day when you do not know their 

times.  

6.5.1 DEFINING A SEQUENCE COLUMN 

The Case Review Administrator can define a Sequence column when setting up the chronology 
document.   

End-users can define one using the Tools > Sequencing > Add column button. (This is the only 
change Chronolator allows to Administrator-defined column headings).  

6.5.2 CHANGING THE SEQUENCE COLUMN HEADING 

The default heading for a Sequence column is Seq, but you can change it once it has been added 
(unless it was defined by the Case Review Administrator): 

Press Tools > Sequencing > Change 

Column Heading: 

 

 

In the form which is displayed,  type the 
new heading - for example ‘Reference’ - 
and press OK: 
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6.5.3 GIVING EVENTS A REFERENCE NUMBER 

Chronolator can add a Reference Number to each event. Numbering can be restarted at 1 on each 
new day if desired. 

Press Tools > Sequencing > Update – 

sequential to give each event a unique number: 

 

Press Tools > Sequencing > Update - group by 

day  if you want the numbering to start at 1 on 
each new day: 
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6.5.4 FORCING EVENTS INTO ORDER 

Sometimes you might not know at what time events happened on a particular day, but you do 
know their order. You can use the Sequence column to specify it. 

In this example from a multi-agency 
chronology, the time has only been given 
for one of the events of March 15, and 
events are in the wrong order: 

 

We can put them in the right order by 
typing the correct sequence numbers in the 
Sequence column of each event . . .  
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. . . and pressing Sort Tables > Ascending:

 

 

 

 You do not always have to update sequence numbers in all the events, as the sort recognises 
decimal numbers. For example, suppose that you now wanted to put event 4 before event 2 (this 
might not make sense in terms of the story, but we will do it here just to illustrate the feature). 

 

Replace the ‘4’ in the event with a number 
between 1 and 2 - ‘1.5’ say: 

 



 Using Chronolator Documents 

Version 3.3 Page 63 of 143 

Press Sort Tables > Ascending to put the 
events into the requested sequence: 

 

Press Tools > Sequencing > Update - group 

by day to replace any decimals with whole 
numbers: 

 

 

If you force events into an incorrect date/time sequence using a Sequence column, 
Chronolator will detect the problem when it checks for errors. 

 

6.5.5 SEQUENCE COLUMN CONFLICTS WHEN IMPORTING A CHRONOLOGY  

Because anybody can add a Sequence column it might happen that an Internal Chronology has 
one but not a Composite Chronology - and vice versa.  

When such conflicts occur, Chronolator lets you decide whether to keep or discard the column. 
See the descriptions of Messages 1030 and 1031 on page 105 for more details. 
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6.6 HIGHLIGHTING SOURCES OF INFORMATION 

Chronolator can highlight events from different agencies in a multi-agency chronology in a number 
of ways. Agencies are distinguished by the Source Prefix they are given when their chronologies 
are imported. 

Press Tools > Highlight Source > Define and 

Do to open the Highlight Source options 
selector: 

  

The main choices you make here use the buttons in the Scope and the Colour Scheme boxes. A 
document containing a detailed description of how these work can be obtained by pressing the 
Show Samples button. 

6.6.1 SCOPE 

The Scope controls how much of the event is highlighted. The lowest scope highlights just the text 
of the agency’s Source Prefix, while the most extensive scope highlights the background of the 
entire row. 

For example, here is how the agency Berrick Police would be highlighted using each Scope: 

Scope    

Text Berrick Police > New 
Town Station > 
Custody records 

Chronolator - the 
Chronology Tool 

Chronolator - the 
Chronology Tool 

Cell Text Berrick Police > New 
Town Station > 
Custody records 

Chronolator - the 
Chronology Tool 

Chronolator - the 
Chronology Tool 

Row Text Berrick Police > New 
Town Station > 
Custody records 

Chronolator - the 
Chronology Tool 

Chronolator - the 
Chronology Tool 
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Scope    

Cell Berrick Police > New 
Town Station > 
Custody records 

Chronolator - the 
Chronology Tool 

Chronolator - the 
Chronology Tool 

Row Berrick Police > New 
Town Station > 
Custody records 

Chronolator - the 
Chronology Tool 

Chronolator - the 
Chronology Tool 

 

6.6.2 COLOUR SCHEME 

Chronolator’s built-in Colour Schemes provide a quick way to set the highlighting for all prefixes. 
For example, this is the Mixed Colours scheme: 

001 
(7.81) 

002 
(6.68) 

003 
(9.01) 

004 
(8.79) 

005 
(6.82) 

006 
(13.76) 

007 
(7.79) 

008 
(5.72) 

009 
(5.35) 

010 
(4.74) 

011 
(4.81) 

012 
(4.60) 

013 
(4.76) 

014 
(4.61) 

015 
(6.37) 

016 
(5.73) 

017 
(7.81) 

018 
(6.68) 

019 
(9.01) 

020 
(8.79) 

021 
(6.82) 

022 
(13.76) 

023 
(7.79) 

024 
(5.72) 

025 
(5.35) 

026 
(4.74) 

027 
(4.81) 

028 
(4.60) 

029 
(4.76) 

030 
(4.61) 

031 
(6.37) 

032 
(5.73) 

This is the Bright scheme: 

177 
(5.25) 

178 
(12.70) 

179 
(19.56) 

180 
(16.21) 

181 
(16.75) 

182 
(9.90) 

183 
(8.59) 

184 
(4.66) 

185 
(5.63) 

186 
(17.52) 

187 
(8.77) 

188 
(5.19) 

189 
(15.82) 

190 
(5.48) 

191 
(6.70) 

192 
(7.31) 

 

The first number in each coloured box is its Chronolator reference number, which can be used if 
you want to override a scheme colour for a particular agency. 

The numbers in brackets give an idea of how legible the highlight might be when viewed on a 
computer screen. They are calculated using the Web Content Accessibility Guidelines (Version 2.0) 
at www.w3.org/TR/WCAG/. Higher values represent better legibility. All of the Chronolator Colour 
Scheme highlights meet or exceed WCAG level AA. 

  

http://www.w3.org/TR/WCAG/
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6.6.3 CUSTOM SETTINGS 

When there are only a few agencies in the chronology a default scheme should make it easy to 
distinguish each one. However, when there are lots of agencies you might get a better distinction 
between them by choosing highlights from different schemes. 

For example, in the Mixed Colours scheme it is quite easy to see the differences between the first 
eight highlights, but probably not so easy to distinguish between highlights 004 and 014. In such a 
case, you can override the scheme colour for one or more agencies by using the Custom Settings 
box. Select the agency you want to modify, and then choose its colour by using the left/right 
arrows or typing in its Reference Number. Note that you will not be able to type in a number that 
is already in use. 

If you have set a custom colour for an agency, Chronolator will retain it when you choose a 
new Colour Scheme unless Reset Custom Settings is ticked. 

6.6.4 PREVIEWING AND DOING 

Highlighting a large chronology can take a few minutes. The Preview  button quickly produces a 
new document illustrating how each agency will appear.  

When you are happy with your definitions, press OK  to highlight the chronology. 

6.6.5 USING HIGHLIGHTS TO GET AN OVERALL PICTURE OF AN AGENCY’S 
INVOLVEMENT 

When reviewing a large chronology, you can get an overview of which agencies did what when by 
highlighting it and then using Word’s Zoom feature to zoom out. For example, the following 
chronology has been highlighted with Scope: Row and Colour Scheme: Bright, and zoomed to 
10%: 
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6.7 PUBLISHING A CHRONOLOGY 

When you have completed a chronology document you can publish it without the Chronolator 
program code so that your recipients will not have to do anything about macros and licence terms 
whenever they open it. 

You can also publish the chronology in a variety of narrative formats. 

Published chronologies are new documents: the original Chronolator document is not 
changed. 

6.7.1 EXACT COPY 

Pressing Publish > Exact Copy 
copies everything to a new 
document, and then displays 
Word’s Save As dialog so you can 
choose where to save it. 

 

6.7.2 NARRATIVE FORMATS 

Although tables are a good way to put a chronology together, they can be unwieldy to read,  
particularly when a single event has a lot of text in one column that spans several pages.  

Chronolator can convert a chronology table to a number of narrative formats, some of which 
include the elapsed time since the start of the chronology. 

Press Publish > Custom 

 

to display the Published 
Document Customisation form: 

PublishCustom02

 

The choices you make influence what headings are displayed in the narrative. 
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6.7.2.1 Main heading - Sequence, Date and Time 

If the chronology contains a Sequence column, it will be the first part of the main heading for each 
event in the chronology. 

The options in the Date / Time format box control how the rest of main heading is displayed: 

 As in document: date and time information will be copied exactly from the document; 
 Elapsed: information about how long it has been since the start of the chronology is included. 

This always includes the number of days. Two sub-options control how the time is treated: 
 Partial: the actual time of the event is used; 
 Full: the elapsed time is used. 

 

The dark grey box is updated as you change 
options to illustrate their effect:  

 

 

 

6.7.2.2 Other headings 

 

After the main heading, the narrative includes information from the non-blank entries for each 
event. The Print column headings box controls whether their individual headings are included. 

 

6.7.2.3 Examples 

Take these events as an example: 
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This is how they will appear in the narrative when various option combinations are used: 

 

As in 
document? 

Elapsed 
Partial? 

Elapsed 
Full? 

Print 
column 
headings? 

Result 

Yes No No Yes 

 

Yes No No No 

 

Yes No  Yes No 
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As in 
document? 

Elapsed 
Partial? 

Elapsed 
Full? 

Print 
column 
headings? 

Result 

Yes Yes  No No 

 

No Yes  No No 

 

No No Yes No 
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6.8 ADD-INS 

If there is something extra you would like Chronolator to do, please contact us to discuss the 
possibility of implementing it in an add-in. 

Requests for new features have previously taken a long time to fulfil owing to the complexity of 
incorporating them and then testing the whole product. Add-ins allow feature requests to be 
satisfied more quickly.  

Chronolator Add-ins are Word templates (dotm files). They should not be confused with the 
Add-ins tab on the Word Ribbon. 

If a Chronolator Add-in is likely to be useful to a wide audience, it will be published on the 
Chronolator web site. Links to available add-ins will be provided at 
www.chronolator.co.uk/download.htm. 

Add-ins include detailed instructions about how to use them. The rest of this section gives brief 
instructions about how to use a typical add-in, in this case called c8Addin03Timeline03. 

6.8.1 LOADING AN ADD-IN 

The first step is to load the add-in into Word. 
Press Tools > Add-ins > Load add-in: 

 

 

Word’s Open dialog will appear. Navigate to 
and open the add-in: 

 

 

http://www.chronolator.co.uk/download.htm
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Message 8000 confirms the add-in has loaded: 

 

Press OK to dismiss the message.  

 

6.8.2 USING AN ADD-IN 

After an add-in has loaded, it updates the Tools 

> Add-ins menu with its functions. In this case, 
the add-in has provided a Create Timeline 
option: 

Add-ins are supplied with their own detailed 
instructions. 
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6.9 DOCUMENT DETAILS AND SYSTEM INFORMATION REPORTS 

The Document Details and System Information reports give information about the chronology 
document and the Word and operating system environment in which it is running. 

6.9.1 THE DOCUMENT DETAILS REPORT 

The Document Details report contains information about the internal structure of the document 
(such as what columns are included, whether they are mandatory and so on), and statistics about 
the tools used while editing it. 

Press Admin > Show 

Document Details: 

 

The Document Details report is displayed. Note the vertical 
scroll bar that allows you to page through it. A horizontal scroll 
bar will also appear if necessary, as shown here. 

 

Press OK when you have finished looking at the report, or if you want to copy the information to a 
new document, press Save As Document. 

The various sections of the report are described below. 

6.9.1.1 Case Reference 

 

The Case Reference assigned by the Case Review Administrator. 
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6.9.1.2 Column Headings 

 

A list of the headings for each column in the chronology table, identifying any Special Columns 
(see Special columns on page 27).  

6.9.1.3 Abbreviations 

 

The entries in the Abbreviations Glossary, showing where they were defined and whether they 
are being used during Chronolator error checking. 
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6.9.1.4 Source Prefixes 

 

The Source Prefixes in a Composite Chronology, assigned when importing other chronology 
documents. 

 

6.9.1.5 Miscellaneous 

 

The order chosen when tables were last sorted, how many Chronolator tables are in the 
document, and how many events are in the chronology. 

6.9.1.6 Statistics 

 

Statistics about the tools used.  

The Run column records how often the tool has been used. 

The remaining columns relate to the last time the tool was used, and are described below. 
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Tables    How many tables were in the document when the tool was started. 

Rows The number of events in the chronology tables (excludes the table headings). 

Field 1 Check Tables The number of errors found. 
Duplicates The number of duplicates found. 
Format Dates Not used. 
Update Seq Not used. 
Merge Not used. 
Publish Custom Not used. 
Abbrev. Review the number of glossary entries which were searched for.  
Abbrev. Report " 
Anonymise " 
Personalise " 
Highlight Src Scope (T= Text, CT=Cell Text, RT=Row Text, C=Cell, R=Row). 

Field2   Check Tables Not used. 
Duplicates Not used. 
Format Dates Not used. 
Update Seq Not used. 
Merge Not used. 
Publish Custom Not used. 
Abbrev. Review The number of glossary entries which were found. If preceded  by 
 an asterisk, the Glossary column was included in the search.  
 cncl means the user cancelled the process. 
Abbrev. Report " 
Anonymise " 
Personalise " 
Highlight Src Colour Scheme (in full, except TxtWhi=Text on White, 
 C&G=ColoursAndGreys). 

Elapsed    Time taken. 

MemPT    Total physical memory on computer. 

MemPF    Free physical memory on computer. 

MemVT Total virtual memory on computer. 

 

6.9.1.7 Software Versions used 

 

The versions of Word and Windows used to produce the document. In a Composite Chronology, 
an asterisk preceding the version information means that that version was used for one of the 
imported chronologies. 
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6.9.1.8 System Processors used 

 

The System Processors (CPUs) used to produce the document. The number in brackets at the start 
of each line is the number of physical processors on the machine.  
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6.9.2 THE SYSTEM INFORMATION REPORT 

The System Information report contains information about the Word and Windows versions on a 
computer. 

Press Help > About 

Chronolator: 

 

Press the System 

Information  button: 

 

The System 
Information report is 
displayed. Note the 
vertical scroll bar that 
allows you to page 
though it. 

 

 

 

Press OK when you have finished looking at the report, or if you want to copy the information to a 
new document, press Save As Document. 
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7 HIDDEN MACROS 

All the tools you usually need are on the Chronolator toolbar. However, there are some special 
commands which are only available using Word’s standard Run Macro facility.  

Note: You should usually only run these macros if asked to do so by Chronolator support staff. 

In Word 2003, you run a macro by 
pressing Tools > Macro > Macros. . . 

 

 

In Word 2007 and later versions, you 
run a macro by pressing Macros on 
the Developer  tab of the ribbon: 

 

 

The Developer  tab is only shown on 
the Ribbon if Word Options > 

Customise Ribbon > Developer is 
ticked: 
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In all versions of Word, you will be 
asked which macro you want to run 
as shown here. 

Select the macro and press Run. 

 

 

 

7.1 IMPORTING A DOCUMENT WITHOUT ADDING A SOURCE 
PREFIX 

Macro c8ImportSpecial_1 imports a document as-is without adding a prefix to its Source of 
Information column. 

7.2 CLEANING UP THE CHRONOLATOR ENVIRONMENT  

Chronolator stores some settings in the user area of the Windows Registry, and sometimes saves 
your work in hidden Word documents. It removes these things when the last Chronolator 
document in a  Word session is closed. If this removal were to fail (if Word crashes for example) it 
might affect opening the next Chronolator Document. 

Macro c8EnvironmentCleanup performs the same clean-up that Chronolator does when it closes 
normally. 

7.3 UNLOADING CHRONOLATOR ADD-INS 

The last Chronolator Document to be closed in a Word session should unload any Chronolator 
Add-ins. If it fails to do so, you can run macro cleanupAddins, which will unload Chronolator Add-
ins but leave any others you might use in place. 
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8 WORKING WITH MICROSOFT WORD TABLES 

This section provides some hints and tips about working with tables in Microsoft Word. Generally 
it gives only one way of achieving a particular end, but there are often other ways. You can find 
more information in Word’s Help, particularly under ‘Keyboard Shortcuts’. 

It is always worth experimenting and asking colleagues for tips. You might feel that you do not 
have time to do so, but ten minutes spent once in a while to find a new time-saver can save you 
much more than that over the years. 

8.1 TERMINOLOGY 

Tables are composed of a number of Rows and Columns. Each individual ‘box’ where a row and 
column meet is called a Cell.  

8.2 USING A MOUSE 

As you move the mouse over a table, the pointer changes. Sometimes it points upwards from left 
to right, sometimes from right to left, sometimes it is the insertion pointer, sometimes a width 
adjuster, and sometimes a black arrow. What happens when you press the mouse depends on 
what the pointer looks like. 

 

      

Figure 5 - mouse pointer shapes 

8.3 SELECTING ITEMS IN A TABLE 

If you want to move or copy an item in a table, you must first Select it. Word highlights whatever 
is selected. 

You can select items with the Mouse or with the Keyboard. 

8.3.1 SELECTING ITEMS WITH THE MOUSE 

The table below shows how to select table items with the mouse.  

Be careful, because if you move the mouse while you are pressing it the effect can sometimes be 
different to what you want as the pointer changes.  

Also, note that there is a difference between selecting the text in a cell and selecting the cell itself. 
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Item to be selected Mouse pointer Mouse action 

Text in a cell 
 

Press and hold at beginning of text, 
drag to desired end, let go. 

Cell  Press left edge of cell. 

Row  Press to left of row. 

Column  Press top edge of column. 

Multiple elements  Press as above and drag across the 
table as desired. 

 

8.3.2 SELECTING ITEMS WITH THE KEYBOARD 

The table below shows how to select table items with the keyboard.  

 

Item to be selected Key 

Text in the cell to the right Tab 

Text in the cell to the left Shift +Tab 

Multiple elements Shift + Arrow keys (experiment!) 

 

8.4 ADDING ROWS TO A TABLE 

To add a row to the end of a table, press the mouse anywhere in the bottom right hand cell and 
press the Tab key.  

To add a single row in the middle of the table using Word 2003 and earlier, select the row above 
which you want it to go, right-click the mouse, and press Insert Rows.  

To add a single row in the middle of the table using Word 2007 and later, press in the row next to 
which you want it to go, right-click the mouse, press Insert, and choose whether to insert Above 
or Below. 

To add several rows to the middle of the table, select the desired number of rows next to which 
you want the new rows to go, right-click the mouse, and press Insert Rows (2003 and earlier - the 
rows will be inserted above) or Insert (2007 and later - choose whether Above or Below). The 
number of rows you selected will be added. 
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8.5 COPYING AND MOVING ITEMS IN A TABLE 

When you have selected an item by one of the methods described above you can copy or move it 
to another place with the Mouse or with the Keyboard. 

8.5.1 COPYING AND MOVING ITEMS WITH THE MOUSE 

Use Windows ‘Drag and Drop’. To Move an item, just do the following; 

 Move the mouse over the selection until the pointer is an arrow pointing upwards from right 

to left like this     ; 
 Press and hold the left mouse key; 
 Move the mouse pointer where you want the item to go; 
 Let go of the left mouse key. 

If you want to Copy instead of Move, hold the Ctrl  key while you do the above. 

8.5.2 COPYING AND MOVING ITEMS WITH THE KEYBOARD 

Use the Windows Clipboard shortcut keys to copy the selected item to the Clipboard: 

 Ctrl + C to copy and leave in place; 
 Ctrl + X to cut from the current location. 

Move the Insertion Point to the desired location, and press Ctrl + V to paste the Clipboard into the 
new location 

8.5.3 UNDOING MISTAKES 

Because of the many types of table elements you can select, it is easy to make a mistake. If you 
want to undo a mistake, you can press the mouse on the Undo button on Word’s Quick Access 
Toolbar (in Word 2003 or earlier, the Standard toolbar), or press Ctrl + Z on the keyboard. 
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APPENDIX A – TROUBLESHOOTING 

If your problem is not described here, please see the FAQ page on the Chronolator website 
www.chronolator.co.uk/faq.htm, which contains information about problems encountered after 
this document was produced. 

Many of the actions described below depend on what version of Word you are using. If you are 
unsure, refer to How can I tell which version of Word I am using? on page 14. 

THE CHRONOLATOR TOOLBAR DOES NOT APPEAR 

The Chronolator toolbar should appear below your other Word toolbars in Word 2003 and earlier 
versions. In Word 2007 and 2010, it should be added to any other custom toolbars on the Add-Ins 
tab on the Ribbon.  

There are two reasons why this might not happen: 

 Your security settings are too restrictive – see Security Settings below; 
 Your Chronolator licence has expired – see Expired Licence on page 94. 

SECURITY SETTINGS 

If you are using Word 2000, XP, 2003, or 2007, please skip to Macros on page 87. 

Protected View (Word 2010 and Word 2013) 

As well as the security settings for running macros which are described below, Word 2010 and 
Word 2013 sometimes open a document in Protected View, in which no editing is allowed. You 
must enable editing if you want to make any changes to the document or use its Chronolator 
facilities. 

 

If you get a warning like this, 
press Enable Editing. 

Skip to Macros on page 87.  

If you get a message like this, 
press it to discover more 
information.  

http://www.chronolator.co.uk/faq.htm
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The resulting display tells you 
more about why Word 
stopped you editing the 
document and offers the 
opportunity to change some 
settings.  

In this example, you would 
press File Block Settings . . . 

 

. . . and then: 

press the circle next to Open 

selected file types in 
Protected View and allow 
editing; 

press OK a few times until you 
return to the Chronolator 
document; 

close and reopen the 
document; 

press Enable Editing as shown 
in the picture on page 84. 

 

 

The File Block settings in the above example are just some of those which can make a 
document open in Protected View. Other settings which activate Protected View can be found in 
the Trust Center (see the instructions on page 89 for information about opening the Trust Center). 
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The Trusted Locations, 
Trusted Documents, and 

Protected View buttons work 
together to influence when a 
document opens in Protected 
View1. 

 

To find out more information 
about the settings you can 
make after pressing one of 
these buttons, press ? at the 
top right hand corner to open 
Word Help for the relevant 
topic. 

 

 

 

Once your document is open in an ordinary view rather than Protected View, you will need to 
ensure macros can run: read on! 

  

                                                      
1
 So do the Trusted Publisher and Trusted App Catalogs buttons, but they are not relevant to Chronolator Documents 
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Macros 

Chronolator works by running macros in the background. Some documents that contain macros 
can harm your computer, so Word allows you to control whether or not they run. 

If the Chronolator toolbar does not appear, your Word security settings are probably too 
restrictive. Following the instructions given here will ensure that Chronolator can run without 
compromising your computer security.  

How to set your macro security levels depends on your version of Word. 

Follow the instructions for your version (Word 2003 and earlier versions below, or Word 2007 
and later versions on page 88), or view one of the videos about Running Macros at 
www.chronolator.co.uk/tutorials.  

Word 2003 and earlier versions 

We recommend that you set your macro security level to Medium; Word will then ask you 
whether you want to run macros whenever you open a document that contains them. 

The pictures below show how to set your security levels in Word 2003. Earlier versions of Word 
might use slightly different menus and security levels. 

 

Press Tools > Macro > 

Security. 

 

 

On the Security Level tab, set 
the level to Medium. 

Press OK. 

 

 

http://www.chronolator.co.uk/tutorials/index.htm
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The change will not take effect until the next time you start Word.  

Close ALL Word documents, and then reopen the Chronolator document.  

Because the settings are not changed until Word restarts, you might confusingly get the following 
message while closing the documents. Just press OK. 

 

 

Word 2007 and later versions 

When you open a Chronolator 
document in Word 2007, the 
area under the Ribbon might 
display a warning message like 
the one to the right. 

If so, skip to Word 2007 
displays ‘Security Warning 
Macros have been disabled’ on 
page 92. 

 

 

In Word 2010 and Word 2013, 
the equivalent message is like 
this. 

Skip to Word 2010 and later 
versions display ‘SECURITY 
WARNING Macros have been 
disabled’ on page 93. 

 

On the other hand, Word 
2007, Word 2010 or Word 
2013 might disable macros 
without telling you. There is 
nothing between the Ribbon 
and the document, as shown 
here.  

If so, continue following these 
instructions. 
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Word 2007 and later versions do not display any warning about macros 

If no macro warning is displayed you need to set some options in Word’s Trust Center: 

1. First of all, open the Word Options dialog. How to do this is slightly different for each Word 
version. Read the appropriate section below; 

2. After opening the Options dialog, carry on reading at Trust Center Settings on page 90. 

OPENING THE WORD OPTIONS DIALOG IN WORD 2007 

Press the          button in the top left corner 
of the display and then press Word Options. 

 

 

OPENING THE WORD OPTIONS DIALOG IN WORD 2010 

Press the File tab, then press Options. 
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OPENING THE WORD OPTIONS DIALOG IN WORD 2013 

Press the File tab. 

 

Press Options. 

 

 

TRUST CENTER SETTINGS 

In the Word Options dialog, press 
Trust Center, then press Trust Center 

Settings. 
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Press Macro Settings. 

Press Disable all macros with 

notification.  

(Somewhat confusingly, although we 
want to enable macros, we have to 
disable them with notification). 

 

 

Press the Message Bar button. 

Press Show the Message Bar in all 

applications … 

 

Press OK a few times until you return to the Chronolator document. 

Close and reopen the Chronolator document. Word will now display a Security Warning telling you 
it has disabled macros; see Word 2007 displays ‘Security Warning Macros have been disabled’ 
below or Word 2010 and later versions display 'SECURITY WARNING Macros have been disabled' 
on page 93 to see how to deal with it. 
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Word 2007 displays ‘Security Warning Macros have been disabled’  

 

Press the Options button next 
to the warning.  

 

 

The dialog box to the right will 
appear.  

Press Enable this content. 

Press OK. 

 

 

Macros are now enabled. 

Chronolator will ask you to 
accept the terms of its licence. 

Press OK. 

 

The Chronolator toolbar will 
appear on the Add-Ins tab as 
shown here.  

  

This is the Online Workbench toolbar. Toolbars in other 
Chronolator documents have different buttons. 
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Word 2010 and later versions display ‘SECURITY WARNING Macros have been disabled’  

 

Press Enable Content. 

 

Macros are now enabled. 

Chronolator will ask you to 
accept the terms of its licence. 

Press OK. 

 

Word might ask if you want to 
‘make this file a Trusted 
document’:  

 

If you answer Yes macros will 
automatically be enabled 
whenever you open this 
document in future. It is 
usually safe to do this, but you 
should be aware of the advice 
Microsoft give in their Help: 
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Whatever you decide, the 
Chronolator toolbar will 
appear on the Add-Ins tab as 
shown here.  

This is the Online Workbench toolbar. Toolbars in other 
Chronolator documents have different buttons. 

 

EXPIRED LICENCE 

You must have a valid licence to run Chronolator. If you do not have one it will tell you so when it 
starts.  

All standard Word features continue to work after the licence has expired, but you will not get 
any Chronolator toolbar. 

More details about licensing are in Appendix C – Licensing on page 140. 
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THE CHRONOLATOR TOOLBAR HAS DISAPPEARED 

If the Chronolator toolbar was there when you opened the document but is no longer visible, you 
might have hidden it by accident.  

In Word 2003 and earlier versions, you might have pressed the Show Only Web Toolbar button to 
the right of the ‘Go’ button on the Web toolbar: 

 

Press it again to show all toolbars. 

 

 

In Word 2007 or later versions, you might have minimised the Ribbon. If so, click the Add-ins tab 
to show the Chronolator toolbar.  

You can maximise the Ribbon if you want it to stay visible. Right-click between any of the tab 
labels (Home and Insert for example) and un-tick Minimise the Ribbon or Collapse the Ribbon: 

Word 2007 Word 2010 Word 2013 

   

 

THE CHRONOLATOR TOOLBAR DOESN’T HAVE ALL ITS BUTTONS 

Chronolator only puts buttons on the toolbar if they can do something useful in the current 
document - for example, since the only thing you can do with a fresh Composite Chronology is to 
import tables into it, the only buttons are Import Tables and Help. 

Having said that, Word hides buttons from the toolbar or ribbon if your window is too small. To 
get them back, just widen or maximise the window. 
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THE CHRONOLATOR PROGRESS BAR DISAPPEARS 

 

Chronolator informs you about the 
progress of most tasks using the 
Progress Bar. For example, while you 
are checking tables it might look 
something like this: 

  

Sometimes, if you are processing a very large file on an older computer with not much memory, or 
on a slow network, the progress bar can disappear from time to time. If this happens, it is often 
possible to make it visible again by double-clicking on the document's icon in the Windows Task 
Bar. 

In any case, disappearance of the progress bar does not affect the processing which is being done. 
When it has finished, Chronolator will display a completion message as usual. 

 

RECOVERING CORRUPTED CHRONOLATOR DOCUMENTS 

Like any Word document, a Chronolator document can become corrupted if problems occur on 
your computer or network while you are working on it. Symptoms can vary. For example: 

 Microsoft Visual Basic messages about a ‘Run-time Error’; 
 Badly formatted or corrupted tables or text; 
 Word crashes or stops working. 

The next few paragraphs describe what you can do to try to recover them. 

RUN-TIME ERRORS 

 

Chronolator uses macros and variables which 
are hidden inside the document. If they 
become corrupted, you might get a message 
similar to this: 

The actual ‘Run-time error’ number and 
description can vary. 

 

 

To recover from this, you will need a blank Chronolator Document. If you still have the original 
which was sent to you, you should use that. If not, contact the person who sent it to you and ask 
for another copy. 
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1. Open the blank Chronolator Document. 
2. Use Word’s Insert File tool: 

In Word 2003 and earlier versions, 
this can be found by pressing 
Insert > File. 

 

 

In Word 2007 and later versions, 
press the Insert tab on the Ribbon, 
and then Object > Text From File.  

 

3. Navigate to and select the corrupted 
document and press Insert. 

 

 

4. Save, close and re-open the document.  

 

 If the document is OK when you re-open it, you have successfully recovered your document 
and can carry on with your work.  

 If not, or if the Insert fails: 
1. follow the instructions in the next section Corrupted tables or text; 
2. go back to Step 1 above. In Step 3, insert the file you will have created in the next 

section. 
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CORRUPTED TABLES OR TEXT, OR WORD STOPS WORKING 

If the tables or text in the document have become corrupted, or Word stops working, try using 
Word’s Open and Repair facility, which is available from Word’s standard Open dialog. 

Reaching the Open dialog 

Getting to the Open dialog is straightforward unless you are using Word 2013: after you have 
started Word, just press File > Open (or in Word 2007,          > Open button).  

In Word 2013, you need to fiddle about a bit1. Here is one way to do it: 

Press the File tab. 

 

Press Open, then Computer, 

then Browse. 

 

 

Using Open and Repair from the Open dialog 

 

Navigate to the corrupted document, but do not left-
or double-click on it; if you do, it will open without 
giving you the opportunity to repair it. 

Right-click on it to select it, and then: 

1. press the small arrow to the right of the Open 
button; 

2. press Open and Repair. 

 

The options you see when pressing on the downward 
arrow will vary depending on your version of Word. 

 

                                                      
1
 This might change when the first Service Pack of Word 2013 is released. 
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Word will try to recover your file. If it succeeds, it will 
display a list of any problems it has corrected.  

 

 

 

 

 

Close the list and save the file. 
 

 

SLOW PROCESSING 

If you find that Chronolator is running unusually slowly, it can sometimes help to close Word and 
start again - don't forget to save your work first!  

For example, on one occasion while Version 3 was being developed, it was found that updating 
sequence numbers in a large file was taking almost four minutes. After saving, closing, and re-
opening the document, the time went down to just over one minute. 

CONFLICTS WITH OTHER WORD ADD-INS 

Sometimes other Word add-ins conflict with Chronolator. When that happens, you can start Word 
without loading add-ins and then open the Chronolator Document from Word's Open dialog.  

STARTING WORD WITHOUT LOADING ANY ADD-INS 

One way to do this is described below. The information was taken from an article on Microsoft's 
web site: http://support.microsoft.com/kb/210565.  

Locate the Windows key 
near the bottom left of your 
keyboard: 

 

http://support.microsoft.com/kb/210565
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Hold down Windows  and 
press R  to open the Run 
dialog: 

 

Press the Browse … button.  

Word's Browse dialog will be 
displayed.  

Find Winword.exe. 

The default locations are as follows:  

Word 2013 C:\Program Files\Microsoft Office\Office15 

Word 2010 C:\Program Files\Microsoft Office\Office14 

Word 2007 C:\Program Files\Microsoft Office\Office12 

Word 2003 C:\Program Files\Microsoft Office\Office11 

Word 2002 C:\Program Files\Microsoft Office\Office10 

Word 2000 C:\Program Files\Microsoft Office\Office 

In the Browse dialog, click 
Winword.exe, and then 
press Open: 

 

The Run dialog will be 
redisplayed, with the path to 
Winword.exe in the Open 
box, surrounded by quote 
marks:  
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Click in the Open box, 
reposition the insertion 
point to the right of the 
closing quotation mark at 
the end of the path 
statement, and type a space 
followed by /a 

 
 

Press OK  to open Word Word will start without any add-ins. 

 

Now open the Chronolator Document from Word's Open dialog. 
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APPENDIX B – CHRONOLATOR MESSAGES 

Chronolator messages fall into two main groups: 

 Messages confirming the results of some processing or offering the user a choice of actions. 
These messages are displayed on the Chronolator Message Form and have unique reference 
numbers. They are described in the next section; 

 Brief messages describing errors found when checking tables. These messages appear as 
Tooltips when the mouse is hovered over a table error, and are also listed at the bottom of a 
Chronolator Document after Check Tables discovers errors. They are described in Check Table 
Error Codes on page 137. 

MESSAGE FORM MESSAGES 

THE MESSAGE FORM 

The Chronolator Message form has three main parts: 

 

 

The upper part contains the 
main message. 

The middle part contains a 
more detailed explanation of 
the message, and suggests 
what actions might be 
appropriate. 

The lower part displays a four-
digit Message Reference 
Number, which can be used to 
locate the message in the 
following sections. 

 

All the messages are shown below, together with further information and suggested actions if 
appropriate. 
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MESSAGES 1000 – 1999 

Messages in this range are issued when importing, merging and sorting tables. 

 

1000 Tables imported 

 All Chronolator tables have been imported. You can merge them into a single 
table by using the 'Merge Tables' button on the Chronolator toolbar.  

Further 
Information 

Chronolator has imported tables from one document into another. The imported 
tables appear after those which were originally in the target document.  

You can continue importing more tables, or merge the tables together. 

 

1003 Invalid document 

 The file you chose is not a Chronolator document and cannot be imported into a 
new Composite Chronology. 

Please refer to the description of this message in the documentation for 
suggestions about what to next. 

Further 
Information 

A new Composite Chronology has no information about the requirements for a 
particular review until you import a Chronolator Document.  

Once this information is in place, Chronolator will import matching tables from 
any Word document; but the first document you import into a blank Composite 
Chronology MUST be a Chronolator Document.   

 

1005 Case References are different 
Composite Chronology: CaseReference1 
Imported Chronology: CaseReference2 

 Press OK to continue with import, or Cancel 

Further 
Information 

Every Chronolator Document is assigned a Case Reference by the Case Review 
Administrator in order to warn against accidentally merging documents which 
relate to different cases. The Case Reference of each document is shown in the 
message. 

Possible 
causes 

You are trying to import tables from a non-Chronolator document, or from a 
Chronolator document which has a different Case Reference. 

Possible 
actions 

Press OK if you want to continue with the import, or Cancel if you do not. 
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1010 'Must-fill' columns are different in source and target documents 

 Press OK to continue with import, or Cancel 

Further 
Information 

Although Chronolator has found tables which have the correct column headings, 
the ‘Must-fill’ columns are different. 

Possible 
causes 

You are trying to import tables from a non-Chronolator document, or from a 
Chronolator document from a different case which has different ‘Must Fill’ 
columns. 

Possible 
actions 

Press OK if you want to continue with the import, or Cancel if you do not. 

 

1015 No Data Tables found in document 

 There are no tables in the document which match the required column headings. 

Further 
Information 

Issued when you process a document which has no tables with the required 
column headings. 

Possible 
causes 

If you are checking, sorting, or formatting a document, the table headings might 
have been accidentally changed. 

If you are importing a document, the headings in the document you are trying to 
import do not match those in the composite. 

Possible 
actions 

Check what column headings Chronolator expects, and if appropriate change 
table headings in the problem document to match the defined headings. 

You can find the expected headings by using the Admin > Show Document 

Details button.  

Alternatively, use the Admin > New Table button to add a table with the correct 
column headings to the bottom of the document. After you have done so, either 
copy any data you have already entered into the new table, or copy the heading 
row from the new table into that of the old one. 

 

1020 Document level mismatch 

 The document you are trying to import cannot be imported into this document as 
it was created with a higher level of Chronolator. 

Create and use a new Composite Chronology using the higher level document for 
this review. Refer to the manuals if you require step-by-step instructions. 

Further 
Information 

Chronolator documents are generally backwards-compatible; that is, newer 
version documents can read older version ones. However, it is not possible to 
guarantee forwards-compatibility.  
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1025 Conflicting and Multiple Definitions 

 The document you are trying to import includes some abbreviations and 
definitions which could be confused with those in this one. Although Chronolator 
will keep track of what was defined where, reading the document might be 
confusing 

If you want to use the anonymisation / personalisation feature in the Composite 
Chronology, you must first resolve these conflicts by changing the abbreviations 
in one of the documents.  

Press Go To List to review the conflicts, OK to continue with the import, or Cancel.   

Further 
Information 

Chronolator will import a document with conflicting and multiple entries in the 
Abbreviations Glossary, but if you want to anonymise or personalise the 
document you must resolve these anomalies. You will be able to do this in the 
Composite Chronology after import, but it is recommended that you do it in the 
source document before importing it. 

 

1026 Conflicting Definitions - Import Cancelled 

 You have chosen to save the conflicting definitions in a new document. 
Chronolator assumes this is because you want some time to review them, and will 
therefore cancel the Import. 

Further 
Information 

Issued if you press Go To List in response to Message 1025. 

 

1030 User-defined sequence column found 

 The document you are trying to import includes a user-defined Sequence column. 
It was probably added because the person completing the document wanted to 
be exact about the order of certain events whose exact times were unknown. 
Chronolator can either add a Sequence column to the table(s) in this document, 
or delete the one in the document being imported.  

Press Add to add a Sequence column to the table(s) in this document, Delete to 
delete the one in the document being imported, or Cancel. 

Further 
Information 

Recommendation: Press Add to add a Sequence column to the Composite 
Chronology so that you can continue to preserve the correct order of events. 
After you have done so, you can use the Tools > Sequencing menu to add 
numbers to the remaining events. 

If you choose Delete, the Sequence column remains in the document being 
imported but is not carried across. 
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1031 Sequence column not found 

 The document you are trying to import does not include a Sequence column, but 
is suitable for import in all other respects. Chronolator can either delete the 
Sequence column from the table(s) in this document, or add one to the document 
being imported.  

Press Add to add a Sequence column to the table(s) in the document being 
imported, Delete to delete the one in this document, or Cancel 

Further 
Information 

Recommendation: Assuming you have deliberately added a Sequence column to 
the Composite Chronology, press Add to add one to the document being 
imported (the document itself is unchanged, just the version of it in the 
Composite Chronology). After you have done so, you can use the Tools > 

Sequencing menu to add numbers to the imported events. 

 

1033 Unable to import 

 Chronolator cannot import anything into this document because of the following 
internal inconsistencies in its structure: 

list of inconsistencies 

Further 
Information 

The document you are trying to import is a Chronolator Document, but it has 
some internal inconsistencies. These are listed in the message. 

Possible 
causes 

The internal variables which Chronolator uses to describe the document structure 
have been lost or corrupted. This can sometimes happen when importing 
documents across a slow network, or it might happen if Word failed while the 
document was being edited some time in the past. 

Possible 
actions 

 if the document is on a slow network, copy it to your desktop and try 
importing the copy; 

 try Repairing the document as described in Recovering Corrupted Chronolator 
Documents on page 96. 

 

1100 Tables merged 

 All Chronolator tables have been merged into a single table. You can sort the new 
table into the correct sequence by using the 'Sort Tables' button on the 
Chronolator toolbar. 

Further 
Information 

Chronolator has merged all the tables in the document.  

The next thing you might want to do is to sort the events into chronological 
order. 
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1105 Cannot merge tables 

 At least one of the tables in this document has a row with the wrong number of 
columns. Please correct this and try again. 

Hint: Use Check Tables to find the problem. 

Further 
Information 

Chronolator has found a table which, although it has the correct headings, 
contains at least one row with the wrong number of columns. 

Possible causes Cells have been merged. 

A row has been added with the wrong number of columns. 

Possible actions Open the offending document and press Check Tables. Chronolator will  
correct any rows with the wrong number of columns and highlight them. You 
should check that Chronolator has put the relevant information in the right 
columns before saving the corrected document. 

 

1110 Cannot merge tables 

 A non-Chronolator table has been found in between the Chronolator tables. 
The offending table is selected. Please move or delete it and try again. 

Further 
Information 

The document contains more than one Chronolator table, and among them is a 
non-Chronolator table. 

Possible causes An ordinary Word table has been inserted by accident. 

A Chronolator table has had its headings changed. 

Possible actions If the table contains no data for import, delete it or move it to the end of the 
document. 

If the table does contain data for import, correct its headings so that 
Chronolator recognises it as a Chronolator table. 
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1120 Multiple chronology tables found 

 This document contains more than one chronology table. 

Press 'Merge' if you want Chronolator to merge the tables and sort them before 
processing. 

Press 'Don't Merge' to process each table individually. 

Press 'Cancel' to return to the document without doing anything. 

Further 
Information 

It is normal to have multiple chronology tables when assembling a Composite 
Chronology, but in other circumstances it might come about by accident. 
Chronolator therefore checks how many tables are in a document before most 
major processes, and if there are more than one if offers to merge and sort 
them before continuing. 

 

1200 Table sorted1 

 Events should now be in Date and Time sequence. 

Some date and time formats can prevent a successful Sort. If that happens, use 
the Format Dates button to put dates in the all-digital format and then sort the 
table again. You can put the dates back to your preferred format afterwards if 
you wish. 

If you know the order of events on a day but not exactly when they occurred, 
you can use a Sequence column to put them in order. You can make one using 
the Tools > Sequencing > Add Column button. 

Further 
Information 

Chronolator puts events with unspecified Times or End Dates before those 
specified with greater detail if the sort is Ascending, or after them if it is 
Descending. 

See Using a Sequence column on page 59 for details about using a Sequence 
column. 

  

                                                      
1 If the document contains multiple tables,  the message heading will be “Tables merged and sorted” or “Tables sorted individually” according to the response to 
Message 1120. 
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1201 Table sorted1 

 Events should now be in Date and Time sequence. 

Some date and time formats can prevent a successful Sort. If that happens, use 
the Format Dates button to put dates in the all-digital format and then sort the 
table again. You can put the dates back to your preferred format afterwards if 
you wish. 

If you know the order of events on a day but not exactly when they occurred, 
you can use the first column to put them in order. 

Further 
Information 

Chronolator puts events with unspecified Times or End Dates before those 
specified with greater detail if the sort is Ascending, or after them if it is 
Descending. 

See Using a Sequence column on page 59 for details about using a Sequence 
column. 

 

1300 Dates formatted 

 All dates have been formatted to one of Chronolator's standard formats.  

If you would like future releases of Chronolator to offer alternative date 
formats please use the suggestion form on our web site 
www.chronolator.co.uk. 

Further 
Information 

Chronolator uses two main formats for dates: 

 dd mmm yyyy (e.g. 01 Feb 2005). This format takes up a small amount of 
space while being unambiguous about months and days (compared to, say 
01.02.05 – is that the first of February or the second of January?); 

 yyyy-mm-dd (e.g. 2005-02-01). This is the ISO 8601 format. It takes even 
less space than the previous format and has the advantage of being an 
International Standard, but most people find it harder to read. 

The day of the week can be added to both of these formats. 

If you would like to be able to set other formats, please contact us via our web 
site.  

                                                      
1 If the document contains multiple tables,  the message heading will be “Tables merged and sorted” or “Tables sorted individually” according to the response to 
Message 1120. 

 

http://www.chronolator.co.uk/suggest_form.htm
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MESSAGES 2000 – 2999 

Messages in this range are issued by the Online Workbench. 

 

2000 Cannot find Master Chronology Document 

 Find the file < ChronolatorMasterChronology.docm > from your original 
Chronolator installation and copy it into folder folderName. 

Further 
Information 

When you create a new Chronology Document, Chronolator looks for the file 
ChronolatorMasterChronology.docm. It issues this message if it cannot find 
it. 

Possible causes You have opened the Online Workbench directly from the installation zip file. 
You need to Extract All Files from the installation file and open the extracted 
Online Workbench.  

The Master Chronology document has been moved or deleted. 

The Online Workbench has been moved, but not the Master Chronology. 

Possible actions Extract All Files from the installation zip file. 

Find the file ChronolatorMasterChronology.docm and copy or move it into 
the folder shown in the message.  

 

2001 Cannot copy Master Chronology Document 

 The Master Chronology Document (ChronolatorMasterChronology.docm) is 
open and cannot be copied. Please close it and try again. 

Further 
Information 

When you create a new Internal or Composite chronology, Chronolator tries to 
open ChronolatorMasterChronology.docm. It issues this message if the file 
is already open. 

Possible causes You have opened ChronolatorMasterChronology.docm. 

Possible actions Close ChronolatorMasterChronology.docm and try again. 
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2002 Master Chronology Document is wrong version 

 The Master Chronology Document (ChronolatorMasterChronology.docm) is the 
wrong version for this Online Workbench. Please copy the correct Master 
Chronology into folder folderName. 

Further 
Information 

When you create a new Internal or Composite chronology, Chronolator opens 
ChronolatorMasterChronology.docm. It issues this message if the file is a 
different version from the Online Workbench. 

Possible causes You have upgraded the Online Workbench without also upgrading the Master 
Chronology. 

Possible actions Install the correct version of ChronolatorMasterChronology.docm in the 
folder shown in the message. 

 

2010 Invalid document 

 The file you chose is not a Chronolator document and cannot be used as a 
model. Please choose another file, or use the Chronolator defaults. 

Further 
Information 

You can only use a Chronolator document as a model for a new one. 

Possible causes You opened an ordinary Word document when choosing an existing file to use 
as a Model in the Case Details Wizard. 

Possible actions Use a Chronolator document as a model, or use the Chronolator defaults. 

 

2015 Invalid document 

 The Chronolator document you chose has internal inconsistencies and cannot 
be used as a model. Please choose another file, or use the Chronolator defaults. 

Further 
Information 

Information about the structure of a Chronolator Document is stored in 
document variables. The document you have chosen as a model has 
inconsistencies in this information, and it is not possible to use it as a Model. 

Possible causes Word might have ended abnormally when it last processed the document, 
causing internal inconsistencies. 

Possible actions Use a different Chronolator document as a model, or use the Chronolator 
defaults. 
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2016 Invalid document 

 The Chronolator document you chose is a blank Composite Chronology and 
cannot be used as a model. Please choose another file, or use the Chronolator 
defaults. 

Further 
Information 

Information about the structure of a Chronolator Document is stored in 
document variables. A blank Composite Chronology does not contain these 
variables, and it is not possible to use it as a Model. 

Possible actions Use a different Chronolator document as a model, or use the Chronolator 
defaults. 

 

2020 Cannot write document details in preamble 

 The area in the Master Chronology preamble where Chronolator writes 
information about the headings in this Chronolator document cannot be found. 

This affects only the document preamble: the table and all Chronolator features 
will work correctly, and it is safe to distribute the document. 

Further 
Information 

When first installed, the Master Chronology contains a bookmarked area in 
which Chronolator writes information about the column headings in a new 
Internal Chronology. That area cannot now be found. 

Chronolator does not write information about the headings in the preamble, 
but continues to create the remainder of the Internal Chronology. 

Possible causes You have customised the Master Chronology and have deleted the area and its 
associated bookmark.  

Possible actions If you want Chronolator to include information about the column headings, 
revert to the original Master Chronology and redo your changes, being careful 
not to delete the relevant area and bookmark. 
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MESSAGES 3000 – 3999 

Messages in this range are issued when Chronolator checks the tables in a Chronology. 

 

3000 Errors found in document (n) 

 Rest the mouse over the box with a cross to see a brief description of each 
error. 

Use the buttons on the Chronolator toolbar to go from one error to the next, or 
press the Go To List button to view a complete list.  

When you have corrected the errors, press the Check Tables button again to 
remove the highlighting. 

Further 
Information 

You pressed the Check Tables button, and Chronolator has found n errors.  

Errors are highlighted in Turquoise, Yellow, or Purple. You can scroll from one 
error to the next using the navigation buttons towards the right of the 
Chronolator toolbar, or see a complete list of them by pressing the button to 
the right of the navigation buttons. 

Chronolator does not check for errors as you type, so you must Check Tables 
after making any corrections in order to remove the highlighting. 

Possible causes Refer to Check Table Error Codes on page 137 for information about each  error 
detected by Chronolator. 

Possible actions No immediate action is necessary, but you should ensure that all errors are 
corrected before returning or publishing the document. 

 

3001 Some rows had the wrong number of columns - fix these first 

 Chronolator has corrected the number of columns in at least one row. 
However, it could not be sure which entry should go in which column. You 
should review these rows now and make sure their entries are in the right 
places. 

It is important to do this now, because now that they have the right number of 
columns they will not be caught in future checks unless they have other errors. 

For ease of identification, the corrected rows are displayed with white text on a 
purple background. 
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3005 Document contains errors - do you want to close it? 

 Please ensure that all errors are corrected before returning or publishing this 
document. 

Press Cancel to resume editing the document and correct them now. 

Press OK to close the document and correct them later. 

Further 
Information 

Chronolator has checked the document as you closed it, and has found errors. 
The errors are highlighted in Turquoise, Yellow, or Purple. You can scroll from 
one error to the next using the navigation buttons towards the right of the 
Chronolator toolbar, or see a complete list of them by pressing the button to 
the right of the navigation buttons. 

Possible causes Refer to Check Table Error Codes on page 137 for information about each  error 
detected by Chronolator. 

Possible actions No immediate action is necessary, but you should ensure that all errors are 
corrected before returning or publishing the document. If you want to correct 
them straight away, press Cancel. If you want to do it later, press OK. 

 

3010 Checked - no errors found 

 Chronolator has checked all the tables in this document and found no errors. 

Further 
Information 

You pressed the Check Tables button, and Chronolator has found no errors in 
this document. 

The buttons on the Chronolator toolbar which can be used to scroll through 
errors are disabled. 

 

3011 No changes found since previously checked 

 No data table appears to have changed since Chronolator last checked this 
document. 

Press Cancel to resume editing. Press Check to re-check the document. 
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3013 Document contains text after chronology tables 

 The area after the chronology tables is reserved for Chronolator and will be 
overwritten if you continue. 

Press Cancel to return to the document and review the text Chronolator found. 
If you want to keep it, move it before the chronology tables before you check 
the tables again. Press OK to delete the text and continue. 

Further 
Information 

You pressed the Check Tables or Duplicates button. Chronolator will overwrite 
whatever follows the chronology tables in the document if you press OK. 

 

3015 Error checking cancelled 

 Please ensure that you check for errors before returning or publishing this 
document. 

Also please note that if you have corrected some previous errors they might still 
be highlighted until the next time you check the document completely 

Possible causes You pressed the Cancel button while Chronolator was checking for errors. 

Possible actions No immediate action is necessary, but you should ensure that all errors are 
corrected before returning or publishing the document. 

 

3020 Processing cancelled 

 No changes have been made. 

Possible causes You pressed the Cancel button while Chronolator was processing. Any changes 
made before you pressed Cancel have been backed out. 

 

3025 n duplicates found 

 You can use the buttons on the Chronolator toolbar to go from one duplicate to 
the next. 

Further 
Information 

Chronolator found n duplicated rows and highlighted them. 

Possible actions You can scroll from one duplicate to the next using the navigation buttons 
towards the right of the Chronolator toolbar. 
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3030 n duplicates deleted 

  

Further 
Information 

Chronolator found n duplicated rows and deleted them. The rows cannot be 
recovered. 

Possible actions If you want to be able to recover deleted rows in future, tick the Copy Deleted 
Rows option when deleting duplicates. 

 

3031 n duplicates deleted 

 Chronolator has saved the deleted rows. Press the 'Go to List' button to view 
them.  

Tip: to re-import them, save the list in a convenient location and use the 
c8ImportSpecial_1 macro. Refer to this message in the manuals for more 
information 

Further 
Information 

Chronolator found n duplicated rows and deleted them. The rows can be 
recovered.  

Possible actions Press ‘Go to List’ to view the saved rows (if you have already moved on before 
reading this, you will find the document is open in the current Word session - 
look for ‘Documentn’ where n is a number).  

Column widths in the saved list might be different from those in the Chronology 
Document, which can present a problem when copying them back in. There are 
a couple of ways to circumvent this: 

 if you want to recover every row and are working in a Composite 
Chronology: 

 save the list as a new document; 
 use macro c8ImportSpecial_1 to import the saved document without 

setting a Source Prefix; 
 merge the tables. 

 if you want to recover only selected rows or are working in an Internal 
Chronology:  

 in the saved list, select and copy the row(s) you want to recover; 
 go back to the Chronology Document; 
 add the same number of rows to the bottom of the chronology table; 
 press in the first blank cell you added to the chronology table; 
 paste the copied row(s). 
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3035 No duplicate rows 

 Chronolator has checked all the tables in this document and found no 
duplicated rows. 

Further 
Information 

Until Chronolator Version 3, identical rows separated by other non-blank rows 
were not identified as duplicates. From Version 3 onwards, duplicate rows will 
be found wherever they occur in a table. 

 

3100 Chronolator table contains vertically merged cells 

 A Chronolator table in this document contains some vertically merged cells. The 
table will be ignored.  

Use the Check Tables button to find the problem cells. 

Further 
Information 

A Chronolator table in the current document contains a cell which spans more 
than one row; this is called a ‘vertically merged cell’. Chronolator is unable to 
process tables containing vertically merged cells. 

Any other Chronolator tables in the document will be processed as usual. 

Possible actions Use the ‘Check Tables’ button to find vertically merged cells.  

Insert one or more rows. Copy and paste any required text into them, then 
delete the rows containing vertically merged cells. 

 

3103 Chronolator table contains vertically merged cells 

 <document name> cannot be imported because a table in it contains some 
vertically merged cells. 

Open the document and use its Check Tables button to find the problem cells. 

Further 
Information 

This message can be issued when you try to import a document into a new 
Composite Chronology. 

A Chronolator table in the document being imported contains a cell which 
spans more than one row; this is called a ‘vertically merged cell’. Chronolator is 
unable to process tables containing vertically merged cells.  

Chronolator will not import a document containing any Chronolator tables with 
vertically merged cells into a new Composite Chronology.  

Possible actions After Import processing completes, open the problem document. Correct the 
problem as described under the ‘Possible Actions’ for message 3100. Retry the 
Import. 
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3105 Chronolator table contains invalid rows 

 <document name> cannot be imported because a table in it contains some 
rows with the wrong number of columns.  

Open the document and use its Check Tables button to find the problem rows. 

Further 
Information 

<document name> is a valid Chronolator Document, but a table in it has at least 
one row with the wrong number of columns. 

Possible actions Open the problem document. Press its Check Tables button and then take the 
actions suggested in Message 3001. Retry the Import. 

 

3107 <process> processing cancelled - invalid table 

 A Chronolator table in this document cannot be processed. No changes will be 
made 

Use the Check Tables button to find (and possibly automatically correct) the 
problem. 

 

3110 Chronolator table contains nested table 

 A Chronolator table in this document contains at least one nested table. The 
table will be ignored. 

Use the Check Tables button to find the nested table(s). 

Further 
Information 

A Chronolator table in the current document contains a cell which in turn 
contains a nested table. Chronolator is unable to process such tables. 

Any other Chronolator tables in the document will be processed as usual. 

Possible actions Use the Check Tables button to find nested tables. Having found one, select it 
and convert it to text. Cut and paste information into the correct columns. 
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3113 Chronolator table contains nested table 

 <document name> cannot be imported because a table in it contains at least 
one nested table.  

Open the document and use its Check Tables button to find the nested table(s). 

Further 
Information 

A Chronolator table in <document name>  table contains a cell which in turn 
contains a nested table. Chronolator is unable to process such tables. 

Nothing will be imported. 

Possible actions Open <document name>  and use its Check Tables button to find nested tables. 
Having found one, select it and convert it to text. Cut and paste information 
into the correct columns. Retry the import. 

 

3120 Chronolator table contains unexpected number of rows 

Expected: m Found: n:  

 When Word prepared the table for processing, it did not find the expected 
number of rows. 

No data will have been lost, but some might be misplaced (either on its own 
new row, or appended to the previous row). 

Further 
Information 

To make some of its processes faster, Chronolator gets Word to store tables in 
an internal array. 

This message is issued if the number of elements in the array does not match 
the number of rows in the table.  

Possible actions If you encounter this message after pressing the Check Tables button, look for 
any rows that are highlighted in purple, or check the error list for error code 
c8n100. 

If it occurs in other circumstances, pressing the Check Tables button might 
show other errors resulting from the potentially misplaced data (for example, 
invalid dates). 

If Check Tables shows no errors, look through the document for misplaced 
data. 

 

3200 Bulleted or Numbered list has been reformatted 

 A Chronolator table in this document contained some bulleted or numbered 
lists. These can cause problems when documents are merged. The bullets or 
numbers have been removed.  

Rather than using Word's list features, you could use 'o' characters or dashes 
for bullets, or use ordinary numbers. 
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MESSAGES 4000 – 4999 

Messages in this range are issued when Chronolator checks the status of your licence. 

 

4000 Multiple licences found 

 Chronolator found more than one licence file. Please delete old ones.  

Look in the same folder as the Online Workbench for files whose names begin 
'Chronolator3Licence'. 

Further 
Information 

The Online Workbench found more than one licence file in its folder.  

Possible causes You have received a new licence and installed it in the correct folder without 
deleting the old licence. 

Possible actions Delete the old licence(s), then close and reopen the Online Workbench. 

 

4005 Invalid licence 

 Chronolator found a licence file, but it is not valid. Please re-install it.  

Look in the same folder as the Online Workbench for a file whose name begins 
'Chronolator3Licence'. Replace that file with the licence supplied to you. 

Possible causes Licences are supplied as .txt files.  The file might have accidentally been edited. 

Possible actions Find your original licence and copy it into the same folder as 
ChronolatorOnlineWorkbench.docm. 
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4010 Temporary Licence Extension Request 

 You can extend your licence for 30 days. This can only be done once, and the 
extension takes effect from the day you request the extension.  

Press OK to extend for 30 days from today, or cancel. 

Further 
Information 

The Chronolator Document licence has expired in the last 90 days. You can 
continue to use standard Microsoft Word features, but Chronolator features 
are disabled.  

You may temporarily extend your licence for 30 days; you can only do this once. 
You might wish to delay extending the licence until you are sure you can 
complete the chronology within 30 days - but be careful not to leave it beyond 
the 90 day grace period. 

Possible causes Licence has expired. 

Possible actions If you only want to use standard Microsoft Word features, press Cancel. 

If you want to use Chronolator’s tools, press OK  to extend the licence for 30 
days. 

 

4020 Licence Expired 

 Your licence has expired and this function is not available. 

Further 
Information 

Running Chronolator features requires a licence. Without a valid licence, only 
standard Microsoft Word features are available. 

Possible causes Licence has expired. 

Possible actions Depends on what document issued this message: 

if issued by the Online Workbench, install a new licence file. then close and 
reopen the Online Workbench. Details about how to get a licence can be 
found on the Chronolator Web site at www.chronolator.co.uk/licence.htm. 

if issued by an Internal or Composite Chronology, ask the Case Review 
Administrator to send you a new licensed copy, and then copy the old 
document into the new one. 

 

4030 Licence Expired 

 Your licence has expired. All standard Microsoft Word features remain 
available, but Chronolator features are disabled. 

Please visit www.chronolator.co.uk for details of how to obtain a new licence. 

Further 
Information 

Refer to Message 4020. 

http://www.chronolator.co.uk/licence.htm
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MESSAGES 5000 – 5999 

Miscellaneous messages. 

 

5000 Open Master Chronology for edit? 

 Are you sure you want to edit the Master Chronology Document rather than 
open the Online Workbench?  

Press OK if you do, or Cancel to close the Master Chronology. 

Further 
Information 

A Case Review Administrator can edit the Master Chronology to change the 
information Chronolator includes when it creates a Chronology Document.  

More often, an Administrator will want to open the Online Workbench. This 
message is issued for confirmation that it is indeed the Master Chronology 
which is desired.  

Possible actions Press OK  to edit the Master Chronology, or Cancel to close it. 

 

5100 Publish document? 

 Publishing a document makes a plain Word copy without any Chronolator code. 
Readers of the copy will not have to agree to any licence terms. After 
Chronolator has created the copy, you will be prompted to save it. 

Press OK to continue, or Cancel. 

Further 
Information 

If you circulate a Chronolator document, readers will have to think about 
macros and accepting licence terms when opening it. Use this button to 
produce a plain Word document which contains no Chronolator code. 

Possible actions Press OK to create a non-Chronolator copy, or Cancel. 

 

5105 Cannot publish a document to the same name 

 Publishing the file using this name would make it lose all its Chronolator 
functions. 

Please try the save again using a different name. 

Further 
Information 

You have tried to publish a Chronolator Document using the same name as the 
document. Overwriting it in this way would stop its Chronolator functions from 
working. 

Possible actions Choose a different name for the published document. 
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5110 Could not copy styles 

 Chronolator encountered a Word error when trying to copy some of the styles 
used in this document. Pagination, text size and other formatting attributes 
might be different in the published version.  

Try Publishing a second time when this attempt has completed: it will probably 
work as expected. 

Possible causes Internal error in Word when Publishing a Chronolator Document  

Suggested 
actions 

Retry Publishing. 

If that fails, try Publishing to a different location. 

 

5115 Publishing cancelled 

 Report production was cancelled at your request. 

 

5120 Publishing cancelled 

 At least one date/time combination in this document is not valid. Chronolator is 
therefore unable to calculate elapsed times. 

Correct the date/time combination and try Publishing again. 

(Suggestion: use the Check Tables button to find any invalid date/time 
combinations). 

Further 
Information 

When you choose one of the Elapsed formats when Publishing a Custom 
chronology, Chronolator needs to calculate the difference between when an 
event started or ended and the start of the chronology. It can only do this if all 
non-blank dates and times are valid. 

Possible actions Press the Check Tables button to find any invalid date/time combinations, and 
correct them. 

 

5130 Show Chronolator error details in published document? 

 This document contains error highlights and / or a list of errors generated the 
last time it was checked. Do you want to include them in the published version? 

(If you do not, please note that page numbers might be different in the 
published version). 

Further 
Information 

It is up to you whether to include details of errors in a published document. 
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5200 Unsupported Word version 

 Chronolator requires Microsoft Word 2000 or later. 

Press OK to continue without Chronolator, or Cancel to exit Word. 

Further 
Information 

Earlier versions of Word are not supported by Microsoft, so we would be 
unable to offer Chronolator support if the root cause of a problem was Word 
itself. 

Possible actions Press OK to close the document. 

Ask your IT department to upgrade Word. They might be persuaded to do so by 
reading the information about Microsoft’s support lifecycle for Office programs 
at http://support.microsoft.com/default.aspx/gp/lifeselectindex#O. 

 

5210 Document type changed 

 Chronolator works by running macros, so documents must be saved as .doc or 
.docm types. Chronolator will change the document to the correct type before 
saving it. 

If you want to save the document as another type, use the Chronolator Publish 
button to make a plain Word copy and then save the Published copy in your 
desired format. 

Further 
Information 

Saving a document in a format which does not support macros would stop it 
being able to use Chronolator.  

Suggested 
actions 

Publish the document to make a plain Word copy which you can then save in 
any other format. 

  

http://support.microsoft.com/default.aspx/gp/lifeselectindex#O
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5220 Performance recommendation  

 Chronolator performs best when Word uses an option that improves the 
performance and reliability of any document stored on a network drive.  

Press OK if you would like Word to use it. 

Further 
Information 

Word XP introduced a performance improvement option for documents stored 
on a network. When the option is set on, a network document is copied to a 
secure location on your computer when you open it. You work on that copy. 
When you save or close the document, Word moves it back to its network 
location. This can lead to dramatic improvements in performance, and also 
provides enhanced protection against network failure. 

Unfortunately, when Microsoft introduced this option they did not make it the 
Word default. Chronolator can set it for you if it is not already on.  

The option applies to all documents, not just Chronolator ones. 

WARNING If the message includes this text: 

WARNING! Chronolator has detected that there might be a conflict with 
another of your options. Please do not press OK without looking up this 
message in the manuals. 

you are using Word XP or Word 2003 and your Word AutoSave options are set 
in such a way as to invoke A BUG IN WORD THAT COULD LEAD TO LOSS OF 
DATA if you accept Chronolator’s recommendation. The bug affects all Word 
documents, not just Chronolator ones. 

Recommendation 1: Initially, press Cancel  so as to leave the performance 
option unchanged, and review the remaining recommendations here. 

Recommendation 2: If performance proves not to be a problem and  you do 
not mind pressing Cancel  when prompted, just do that - you will only be 
prompted once a day. 

Recommendation 3: If performance is a problem, or you get fed up with 
pressing Cancel so often, ask your Administrator to contact Berrick Computing 
for more details about Bug 51. 

Suggested 
actions 

If the above WARNING is not included in the message, or if it is and you have 
reviewed the above recommendations and want to improve performance: 

 Press OK  to allow Chronolator to set the option; 
 Close and re-open the document when prompted. 

Turning the 
option off 

If you decide later that you want to turn the option off, you can do so as 
follows: 

 Word XP and 2003  

On the main Word menu bar, press Tools > Options, then press the Save tab: 
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Un-tick Make local copy of files stored on network or removable drive. 

Press OK. 

 Word 2007 and later  

Open the Options dialog (see Opening the Options Dialog on page 89). 

 

Press Advanced and scroll down to Save. 

Un-tick Copy remotely stored files onto your computer, and update the 
remote file when saving. 

Press OK. 
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5221 Performance recommendation  

 Chronolator has set the option. Please close and re-open this document to 
allow it to take effect.  

Further 
Information 

See Message 5220. 

 

5230 Change tracking alert!  

 <document name> is using Word's Track Changes feature. Tracking changes can 
cause severe problems when processing tables.  

Press OK to accept all tracked changes and turn change tracking off, or Cancel if 
you want to review them. 

Further 
Information 

Using Tracked Changes with tables can cause problems in any Word document, 
not just a Chronolator one. Microsoft are aware of this, but at the time of 
writing there is no fix on the horizon. 

 

5231 <process> cancelled - change tracking active  

 <document name> is using Word's Track Changes feature. 

The Tracked Changes feature can cause severe problems when processing 
tables. 

Further 
Information 

The named <process> was cancelled because change tracking is active in the 
document <document name>. 

Possible causes You replied Cancel to Message 5230. 

You replied OK to Message 5230, but Chronolator was unable to turn off 
tracked changes. 

Suggested 
actions 

Review the tracked changes if you wish, then retry the cancelled process and 
reply OK to Message 5230. 
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5232 Unable to determine Tracked Changes status in <document name> 

 Chronolator could not determine whether Tracked Changes is on in the 
document because it appears to be locked by another user. 

To be on the safe side, Chronolator will assume that Tracked Changes is on. 

The Tracked Changes feature can cause severe problems when processing 
tables. 

Possible causes Someone else is editing the document and Chronolator could not determine 
whether Change Tracking is on. 

Suggested 
actions 

Close the document and wait for the other person to close it as well. Reopen 
the document. 

 

5233 Unable to turn off Tracked Changes in <document name> 

 Chronolator could not turn off Tracked Changes. 

This is probably because the document has been protected. 

The Tracked Changes feature can cause severe problems when processing 
tables. 

Possible causes <document name> has been protected so that the Tracked Changes feature 
cannot be turned off. 

Suggested 
actions 

Turn off the protection. You might need to supply a password. 

The relevant protection feature can be found in various places: 

 Word 2013 - the Track Changes dropdown or the Restrict Editing 
button on the REVIEW tab of the Ribbon; 

 Word 2010 - the Restrict Editing button on the Review tab of the 
Ribbon; 

 Word 2007 - the Protect Document dropdown on the Review tab of the 
Ribbon. 
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5300 Open Web Tutorials? 

 Chronolator cannot find the Tutorials on your computer. 

Press OK to go to the Web tutorials (requires an Internet connection). 

Further 
Information 

A full set of tutorials is maintained on the Web for non-licensees and for 
licensees who choose not to install them. 

Possible causes The Chronolator tutorials are not included in the standard installation packages. 

It is unlikely that the tutorials will exist on computers belonging to non-
licensees who receive Internal Chronologies. 

Possible actions Press OK  if you are connected to the Internet and want to view the Web 
tutorials. 

 

5310 Web connection error 

 Chronolator cannot find the Tutorials on the Web. 

If you are sure your connection is OK, please report the problem to us using the 
form on our website: www.chronolator.co.uk/bug_form.htm. 

Further 
Information 

The Web tutorials cannot be found. 

Possible causes You do not have an open Internet connection, or your organisation might have 
limited your access. 

Possible actions Connect to the Internet or contact your IT department to grant you access to 
our website as appropriate. 

If your connection is open and unlimited, please report the problem using the 
form described in the message. 

 

5320 Cannot save the document using the name you chose 

 A document with that name is already open in Word.  

Please try the save again using a different name. 

Further 
Information 

Word does not allow you to save a document with the same name as one which 
is already open. 

Possible causes You have tried to save a document using the same name as an open document.  

Possible actions Retry the save using a different name. 

  

http://www.chronolator.co.uk/bug_form.htm
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5321 Cannot overwrite Chronolator system file 

 Saving the file using this name might overwrite documents which Chronolator 
needs to function. 

Please try the save again using a different name. 

Further 
Information 

Chronolator will not let you save a file using one of its own reserved file names 
(ChronolatorMasterChronology and ChronolatorOnlineWorkbench). 

Possible actions Retry the save using a different name. 

 

5322 Permission Denied 

 You do not have Write access to the requested folder. 

Please try to save the file in a different folder. 

Further 
Information 

You have tried to save the file in a folder to which you do not have Write access 

Possible actions Save the file in a folder to which you do have Write access, such as My 
Documents. 

If you think you should have Write access to the folder, contact your IT 
department. 

 

5323 File name changed 

 Word has changed the file name since you last saved this document. If you are 
unaware of this change you might not be able to find the file after you close it. 

After you press OK, you will be asked to save the document using a name of 
your choice. 

Please refer to the manuals if you frequently get this message. 

Further 
Information 

You might have become a victim of a bug in Word. 

Possible actions Save the file in the right place with the right name. 

If the message is issued often, please ask your Administrator to contact Berrick 
Computing, quoting Message 5323. 
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5400 Internal inconsistencies in Chronolator document 

 Chronolator has found internal inconsistencies in this document, which are 
detailed below. 

These may stop Chronolator functions working. Standard Word features are 
unaffected.  

<list of inconsistencies> 

Further 
Information 

Information about the structure of a Chronolator Document is stored in 
document variables. Inconsistencies in this information might stop some 
Chronolator functions working. However, standard Word functions should not 
be affected. 

Possible causes The document is stored on a slow network. 

Word might have ended abnormally when it last processed the document, 
causing internal inconsistencies. 

Possible actions If the document is on a slow network, close it and try opening it again. If that 
does not work, copy the document to your Desktop and work on that copy; 
remember to move it back to the network when you have finished. 

If the document is indeed corrupted, open a valid Chronolator Document with 
the correct table headings (for example, the original document sent to you by 
an Administrator), and copy the contents of the problem document into it. Save 
this new document and use it from now on. 

 

5402 Unable to create table 

 Chronolator cannot create a new table in this document because of following 
internal inconsistencies in its structure: 

<list of inconsistencies> 

Further 
Information 

See Message 5400 for suggestions about how to resolve these inconsistencies. 
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5403 Unable to set styles 

 Chronolator could not set some document styles because the file appears to be 
locked by another user. 

This will only affect the fonts used to display any error messages at the end of 
the document. 

Further 
Information 

If there are any error messages at the end of the document, they might not be 
displayed in the usual font. 

Possible causes Someone else is editing the document. 

Suggested 
actions 

Close the document and wait for the other person to close it as well. Reopen 
the document. 

 

5500 Clipboard Unavailable 

 Chronolator could not access the clipboard. Another application is probably 
using it. 

Press OK to try again, or Cancel. 
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MESSAGES 6000 - 6999 

Chronolator issues these messages when an unexpected error occurs. 

 

6000 Unexpected processing error 

 Please note the information below and report it to us using the form on our 
website: www.chronolator.co.uk/bug_form.htm. 

<problem description> 

Further 
Information 

Chronolator has encountered an unexpected error. The problem description 
provided will help diagnose the error.  

Possible actions Please note the problem description and what you were doing at the time and 
send the details to us using the form on the website. The more information you 
can provide the better. The Document Details and Word Environment reports 
will be useful if you can produce them after closing and reopening the 
document. See Document Details and Word Environment Reports on page 73. 

  

http://www.chronolator.co.uk/bug_form.htm
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MESSAGES 7000 - 7999 

Chronolator issues these messages when you use the Anonymisation and Highlighting features. 

 

7000 Glossary contains duplicated entries 

 Anonymisation and Personalisation are not possible because the Abbreviations 
Glossary contains duplicated abbreviations and / or duplicated definitions. 

You can update the glossary and related text using Admin > Abbreviations. 

Possible actions See Changing an abbreviation on page 52. 

 

7010 Warning! 

 Formatting introduced while using the Anonymisation feature will be lost when 
Checking or Merging Tables. It is strongly recommended that you do not use 
this feature until you have no further need to Check or Merge tables. 

Press OK to continue, or Cancel. 

This message will not be shown again during this session.   

Further 
Information 

The Bold, Italic, Underline formatting which can be applied using the 
Anonymisation feature will be lost if you Check or Merge tables. 

Possible actions Ensure you have done all the error-checking and merging you require before 
using the Anonymisation feature. 

 

7030 Abbreviation Not Used 

 The selected abbreviation and definition are not used in the text. 

 

7031 Abbreviations Not Used 

 The selected abbreviations and definitions are not used in the text. 

 

7032 Nothing to anonymise 

 The selected abbreviation is not used in the text. 

OR 

The selected abbreviations are not used in the text. 
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7033 Nothing to personalise 

 The selected abbreviation is not used in the text. 

OR 

The selected abbreviations are not used in the text. 

Further 
Information 

If the message includes the text ‘with the specified formatting’, you have asked 
Chronolator only to look for abbreviations which have Bold, Italic, Underline 
formatting by ticking the box on the Anonymisation form. See the comments 
about the Use formatting checkbox on page 56. 
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MESSAGES 8000 - 8999 

Chronolator issues these messages when you use Chronolator Add-ins. 

 

8000 Add-in loaded successfully 

 Please refer to the documentation accompanying the add-in for details about 
what it does and how to use it. 

 

8010 Add-in failed to load 

 <document> 

<error message>   

Further 
Information 

Add-in <document> failed to load. 

The reason is given in  <error message>   

Possible actions Ensure that <document> is a valid Chronolator Add-in for the version of 
Chronolator. 

If you think it is, contact your Administrator and ask them to report the 
problem to Berrick Computing. Give them as much detail as possible. 

 

8020 Cannot open document - a Chronolator Add-in is loaded 

 Only one Chronolator document can be open while a Chronolator Add-in is 
loaded. 
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CHECK TABLE ERROR CODES 

These messages appear as Tooltips when the mouse is hovered over a table error, and are also 
listed at the bottom of a Chronolator Document after Check Tables discovers errors. 

 

c8n100 This row contained the wrong number of columns. Chronolator has rectified 
this, but you should check that the each entry is under the right heading 

Further 
Information 

The number of columns in this row was different from the number of column 
headings. Chronolator has added or deleted columns to rectify this. No data will 
have been deleted, but it might not be in the correct column.  

Possible actions Review where Chronolator has put the original data, and move it into another 
column if necessary.  

 

c8n120 This column is blank, but must always be completed. Add some text. 

Further 
Information 

The Case Review Administrator has deemed it mandatory that this column 
should always be completed.  

Possible actions Add text to the column.  

 

c8n125 'As Above', 'See Above', or ditto marks are not allowed. 

Further 
Information 

This can seem annoying when you are entering many similar events into an 
Internal Chronology. However, remember that the Administrator will probably 
merge your chronology with others. When merged chronologies are sorted, ‘As 
Above’ and similar rows may well become separated from their previous 
predecessors.  

Possible actions Copy and paste text from the previous row.  

 

c8n130 Cell is vertically merged. Copy any text to another row or rows and delete all 
rows containing this cell. 

Further 
Information 

The table cell in question spans more than one row; this is called a ‘vertically 
merged cell’. Chronolator is unable to process tables containing vertically 
merged cells. 

Possible actions Insert one or more rows. Copy and paste any required text, then delete all rows 
containing the problem cell. 
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c8n135 Cell contains a nested table. Convert the nested table to text. 

 

Further 
Information 

The table cell in question contains a nested table. This can happen if you select 
the relevant option when pasting from on table into another. 

Possible actions Convert the nested table to text, and make sure the information it contains is 
under the correct column headings. 

 

c8n140 The '>' character is not allowed in this column. 

Further 
Information 

Chronolator uses the ‘>’ character to keep track of the Source of Information in 
a Composite Chronology. It is, therefore, not allowed in an Internal Chronology. 

Possible actions Use a different character. 

 

c8n145 Invalid Source 

Further 
Information 

The Source of Information column contains an invalid Source Prefix. Source 
Prefixes are assigned when you import a chronology document and cannot be 
changed afterwards. 

Possible actions Press Admin > Show Document Details to see the list of prefixes which are 
valid in this document. 

 

c8n210 Invalid date, or invalid date format. Try another format (e.g. '01 feb 2006' or 
'01.02.06'). 

Further 
Information 

Chronolator cannot interpret the date in this cell. It might be in a recognisable 
format but be invalid (e.g. ‘32 May 2007’), or Chronolator might not recognise 
the format. 

Possible actions Enter a date in a recognisable format. Chronolator recognises most common 
date formats. 

 

c8n220 Invalid time, or invalid time format. Try another format (e.g. '1.20 am', '0120', 
or '01.20'). 

Further 
Information 

Chronolator cannot interpret the time in this cell. It might be in a recognisable 
format but be invalid (e.g. ’25:00’), or Chronolator might not recognise the 
format. 

Possible actions Enter a time in a recognisable format. The message text indicates a number of 
formats that Chronolator recognises. 
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c8n230 Event ends before it starts. 

Further 
Information 

None. 

Possible actions Change the start or end dates / times of the event. 

 

c8n240 Start of event is out of sequence. 

Further 
Information 

None. 

Possible actions Check the information about when the event started. If it is correct, you can use 
the Sort Tables button to put the event in the proper place in the table. 

 

c8n250 End of event is out of sequence. 

Further 
Information 

None. 

Possible actions Check the information about when the event finished. If it is correct, you can 
use the Sort Tables button to put the event in the proper place in the table. 

 

c8n300 At least one abbreviation is not defined. Change the abbreviation, or use the 
Admin > Abbreviations > Define button to define a new one. Put multiple 
abbreviations on separate lines, or separate them with commas. 

Further 
Information 

None. 

Possible actions As suggested in the note. 
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APPENDIX C – LICENSING 

Chronolator is licensed software. You can evaluate its features without having a licence, but the 
documents it creates include a watermark on every page. If you do not want these watermarks to 
appear, Chronolator must be licensed. 

When you open the first Chronolator Document in a particular Microsoft Word session, a form is 
displayed where you can accept or decline the licence terms. The Licensee and Expiry Date are 
shown on the form, and the full terms of the licence can be displayed by pressing the View 

Licence button. If you do not accept them, the document will close.  

Chronolator Documents and the Chronolator Online Workbench are licensed in different ways.  

ONLINE WORKBENCH LICENCE  

When you buy a licence to use the Chronolator Online Workbench, you are given a small file 
whose name begins Chronolator3Licence.  

The licence is specific to a particular purchaser, and the licence file should not be distributed to 
anyone else except as allowed in the licence terms.  

Details about how to get a licence for the Online Workbench can be found on the Chronolator 
Web site at www.chronolator.co.uk/licence.htm. 

To install the licence, copy it into the same folder as the Online Workbench. The Online 
Workbench propagates the licence information into the Chronolator Documents it creates. 

CHRONOLATOR DOCUMENT LICENCE  

Chronolator Document licences are created by the Online Workbench and stored internally in the 
Chronolator Document.  

LICENCE PERIOD 

A Chronolator licence is valid for a specified period.  

 For the Online Workbench, the period is contained in the licence file;  
 Internal Chronologies are licensed for four calendar months from the day they are created1;  
 Composite Chronologies created by the Online Workbench are licensed for the same period as 

the Online Workbench; 
 Composite Chronologies created by Local Administrators using the facilities included in an 

Internal Chronology expire at the same time as that Internal Chronology. 

 

                                                      
1
 Internal Chronologies created by Berrick Computing Ltd under the terms of a Single Case licence are licensed for the period agreed with the purchaser 

http://www.chronolator.co.uk/licence.htm
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WHAT HAPPENS WHEN A LICENCE EXPIRES 

When a licence expires, all the standard Microsoft Word features continue to function, but the 
Chronolator toolbar and buttons do not appear, and no Chronolator features are available.  

Chronolator Documents whose licence has expired can be imported into licensed Composite 
Chronologies as if they were still licensed. 

TEMPORARY LICENCE EXTENSION 

Unavailability of records and other factors can sometimes delay the completion of a Chronolator 
Document beyond its expiry date. Chronolator Documents therefore provide a simple means to 
extend a licence without having to contact Berrick Computing Ltd. 

For 90 days after a Chronolator Document expires, an Extend Licence button appears on the 
Licence Acceptance form. Pressing it extends the licence for 30 days. Only one such extension can 
be made, so you should not do this until you know you can complete the chronology within those 
30 days. 

‘REFRESHING’ AN EXPIRED LICENCE 

If a Chronolator Document has exceeded the temporary licence renewal threshold, the Case 
Review Administrator should create a new blank one with the correct column headings. Having 
done so, the contents of the expired document can be incorporated into the new one using 
Word’s standard Insert File feature. Details of how to use it are in Step 2 of the ‘Recovering 
corrupted Chronolator Documents’ section on page 97. 
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APPENDIX D - HOW CHRONOLATOR DEALS WITH EVENTS WITH 
IMPRECISE DATES OR TIMES 

In the real world, events begin and end on exact dates and at exact times. In a chronology, not all 
this information might be known for a particular event. Indeed, in some chronologies, the 
administrator might decide not to collect some of this information at all.  

Chronolator always ensures that the Start Date of event is specified, but the Start Time, End Date 
and End Time are often missing. How does it deal with such events? 

ASSUMPTIONS 

INDIVIDUAL EVENTS 

When information about the exact start or end of an event is missing, Chronolator makes the 
following assumptions so that it can be processed. 

1. If Start Time is missing, it is assumed to be midnight (00:00); 
2. If End Date is missing, it is assumed to be the same as Start Date; 
3. If End Time is missing, it is assumed to be the same as Start Time. 

DURATIONS 

Sometimes the elapsed time between two instants needs to be calculated; for example, the 
interval between two events, or between the start and end of a single event. Chronolator assumes 
that any information missing in the later instant is the same as that of the earlier one.  

ASSUMED INFORMATION IS NEVER DISPLAYED 

Whatever assumptions Chronolator might make about missing information, it will never display 
those assumptions explicitly. For example: 

 an event which Chronolator assumes to start at midnight, for example, will never include 
that time in any display; 

 a duration based upon an assumed time will only include date-based information. 

OVERRIDING CHRONOLATOR’S ASSUMPTIONS  

Sometimes you might know the order in which events happen even though you do not know their 
dates and time exactly. In these circumstances you can use a Sequence column to ensure that 
Chronolator sorts events in the order you specify. The Check Tables  button can still be used to 
check that such ‘manually’ sorted events are in a valid order. For more information about the 
Sequence column, see  Using a Sequence column on page 59. 
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APPENDIX E - CHRONOLATOR TERMINOLOGY 

 

Term Meaning 

Chronolator Document 
Chronology Document 

A document containing one or more tables created by 
Chronolator. 

Internal Chronology A Chronolator Document specific to a particular 
organisation or department. 

Composite Chronology A Chronolator Document containing information from two 
or more Internal Chronologies. 

Case Review Administrator Someone who sets up Chronology Documents using the 
Online Workbench. 

Local Administrator Someone who distributes an Internal Chronology for others 
to complete and then merges the results into a Composite 
Chronology. 

Online Workbench Used by a Case Review Administrator to create and manage 
Chronolator Chronology documents. 
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